hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Bertozzi <theo.berto...@gmail.com>
Subject Re: Unable to get data of znode /hbase/table/mytable.
Date Tue, 22 Apr 2014 16:10:29 GMT
On Tue, Apr 22, 2014 at 9:00 AM, yeshwanth kumar <yeshwanth43@gmail.com>wrote:

> @matteo
> present znode is at /hbase/table where it is empty.
> where as all my tables are present in /hbase/table94
> now  webapp isn't reading the data from hbase.
>

cdh 4.5.0 doesn't write in /hbase/table due to a compatibility issue
/hbase/table94
is used.
(see HBASE-6710 for details)

On Tue, Apr 22, 2014 at 6:56 PM, Matteo Bertozzi <theo.bertozzi@gmail.com
>wrote:

>
> > /hbase/table94 is a "compatibility" znode that replaces /hbase/table
> > if you want more details take a look at HBASE-6710.
> >
> > what is the problem of looking into /hbase/table94 instead of
> /hbase/table?
> >
> > Matteo
> >
> >
> >
> > On Tue, Apr 22, 2014 at 5:18 AM, yeshwanth kumar <yeshwanth43@gmail.com
> > >wrote:
> >
> > > Hi,
> > >
> > >
> > > i am running webapp written on jaxrs framework which performs CRUD
> > > opereations on hbase.
> > >
> > > app was working fine till last week,
> > > now when i perform reading opeartion  from hbase i don't see any data,
> i
> > > don't see any errors or exceptions but i found this lines in the log
> > >
> > > *""Unable to get data of znode /hbase/table/myTable because node does
> not
> > > exist (not an error)"".*
> > >
> > > i followed this<
> > > https://blog.cloudera.com/blog/2013/10/what-are-hbase-znodes/>
> > > cloudera
> > > article about znodes and this is what i found,
> > >
> > > *$[zk: localhost:2181(CONNECTED) 14] ls /hbase*
> > > *[splitlog, online-snapshot, unassigned, table94, root-region-server,
> rs,
> > > backup-masters, table, draining, master, shutdown, hbaseid]*
> > >
> > > all the tables were present in /hbase/table94, where as /hbase/table is
> > > empty.
> > >
> > > i know what is the problem now,
> > > but i don't know how to solve it.
> > >
> > > can someone help me with this issue.
> > >
> > > Thanks,
> > > Yeshwanth
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message