hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: HBase 0.94 on hadoop 2.2.0 (2.4.0)
Date Fri, 25 Apr 2014 12:16:22 GMT
Can you paste bin the output of the following command ?

mvn dependency:tree

Thanks

On Apr 25, 2014, at 4:32 AM, Lukáš Drbal <lukas.drbal@gmail.com> wrote:

> Hi Guys,
> 
> Ted thank you for -Dhadoop.version=2.2.0 it works.
> 
> Now i have master running on hadoop 2.2.0 but region server don't run.
> Full log - https://gist.github.com/LesTR/57e2a8f2afe419b42405
> 
> 
> 2014-04-24 12:00:18,103 WARN
> org.apache.hadoop.hbase.regionserver.HRegionServer: Exception in
> region server :
> java.lang.UnsupportedOperationException: This is supposed to be
> overridden by subclasses.
>        at com.google.protobuf.GeneratedMessage.getUnknownFields(GeneratedMessage.java:180)
>        at org.apache.hadoop.hbase.protobuf.generated.HBaseProtos$RegionServerInfo.getSerializedSize(HBaseProtos.java:883)
>        at com.google.protobuf.AbstractMessageLite.toByteArray(AbstractMessageLite.java:62)
>        at org.apache.hadoop.hbase.regionserver.HRegionServer.createMyEphemeralNode(HRegionServer.java:1148)
>        at org.apache.hadoop.hbase.regionserver.HRegionServer.handleReportForDutyResponse(HRegionServer.java:1109)
>        at org.apache.hadoop.hbase.regionserver.HRegionServer.run(HRegionServer.java:758)
>        at java.lang.Thread.run(Thread.java:745)
> 
> From this exception i see a problem with protobufers libs. I change
> version from 2.4.0a to 2.5.0 as is mentioned in book and compiled with
> -Dprotobuf.version=2.5.0
> 
> In classpath exits only 2.5.0 version
> root@hadoop-master:/usr/share/hbase/lib# hbase classpath | tr ":" "\n"
> | grep -i proto
> /usr/share/hbase/bin/../lib/protobuf-java-2.5.0.jar
> 
> root@hadoop-master:/usr/share/hbase/lib#
> 
> Any hint please?
> 
> 
> L.
> 
> 
> 
> 
> 
> 
> 2014-04-24 18:33 GMT+02:00 Ted Yu <yuzhihong@gmail.com>:
> 
>> Support for hadoop 3.0 is tracked by HBASE-6581
>> 
>> FYI
>> 
>> 
>> On Thu, Apr 24, 2014 at 2:49 AM, Azuryy Yu <azuryyyu@gmail.com> wrote:
>> 
>>> Hi Ted,
>>> Sorry I misunderstood something, I found these issues during built
>>> hbase-0.9* against hadoop trunk.
>>> 
>>> we can consider trunk as Hadoop-3.0, so hbase doesn't support 3.0 is
>>> reasonabl currently.
>>> 
>>> 
>>> 
>>> On Thu, Apr 24, 2014 at 10:32 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>>> 
>>>> Looking at branch-2 , we can
>>>> find
>> hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/http/HttpServer.java
>>>> 
>>>> Please refer to this commit:
>>>> 
>>>> r1561967 | suresh | 2014-01-27 23:50:54 -0800 (Mon, 27 Jan 2014) | 1
>> line
>>>> 
>>>> HADOOP-10292. Restore HttpServer from branch-2.2 in branch-2.
>> Contributed
>>>> by Haohui Mai.
>>>> 
>>>> bq. also some MapReduce issues
>>>> 
>>>> Can you list what issues they're ?
>>>> 
>>>> Thanks
>>>> 
>>>> On Wed, Apr 23, 2014 at 6:56 PM, Azuryy Yu <azuryyyu@gmail.com> wrote:
>>>> 
>>>>> This is a serious issue, HBase-0.94 doesn't support Hadoop-2.4,
>>>> HttpServer
>>>>> was removed in the Hadoop2.4, but HBase InfoServer still use it, and
>>>> there
>>>>> are also some MapReduce issues, so if you build HBase-0.94 against
>>>>> Hadoop-2.4, it will fail.
> 
> 
> 
> -- 
> Save The World - http://www.worldcommunitygrid.org/
> http://www.worldcommunitygrid.org/stat/viewMemberInfo.do?userName=LesTR
> 
> LesTR

Mime
View raw message