hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijayakumar Ramdoss <nellaivi...@live.com>
Subject Re: connecting to hbase remotely
Date Sun, 09 Mar 2014 13:29:45 GMT

Please You should probably build something around the HTablePool that comes with HBase.
http://stackoverflow.com/questions/17661217/hbase-connection-pool-in-tomcat

Thanks 
Vijay Ram
Sent from my iPad

> On Mar 7, 2014, at 1:40 AM, "yeshwanth kumar" <yeshwanth43@gmail.com> wrote:
> 
> thanks Jean and Ted,
> 
> issue was resolved, i was using multiple configurations for two different
> tables, for one table i specified config property but for another i missed
> it,
> that caused the issue.
> 
> 
> in my application i made Rest service on hbase data,
> for every call i am creating a connection to hbase, is there a way to do it
> efficiently like persisting connection or kind of connection pool.
> need ur suggestions for improving performance.
> 
> 
> thanks,
> Yeshwanth
> 
> 
> 
> 
>> On Thu, Mar 6, 2014 at 11:14 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>> 
>> Looks like you were serving requests using web server.
>> 
>> Is hbase-site.xml in the classpath ?
>> 
>> Thanks
>> 
>> 
>> On Thu, Mar 6, 2014 at 3:05 AM, yeshwanth kumar <yeshwanth43@gmail.com
>>> wrote:
>> 
>>> Hi i am using HBase 0.94.6-cdh4.5.0
>>> 
>>> i conected to hbase by setting config explicitly in my code through
>>> config.set zookeeper quorum property.
>>> 
>>> i am able to read the hbase table data properly,it is connecting to the
>>> host specified in config
>>> log:
>>> 
>>> " Creating new Groups object
>>> Group mapping
>> impl=org.apache.hadoop.security.ShellBasedUnixGroupsMapping;
>>> cacheTimeout=300000
>>> hadoop login
>>> hadoop login commit
>>> using local user:UnixPrincipal: root
>>> UGI loginUser:root
>>> hconnection opening connection to ZooKeeper with ensemble (
>>> 192.168.2.51:2181
>>> )"
>>> 
>>> but when i try to write data to hbase it is trying to connect to the
>>> localhost as
>>> log:
>>> "hconnection opening connection to ZooKeeper with ensemble
>>> (localhost:2181)"
>>> 
>>> 
>>> complete log for writing to hbase is here <http://pastebin.com/kAp1h4ru>
>>> 
>>> am i missing anything, do i need to specify anyother properties
>>> 
>>> can some one help me with this issue.
>>> 
>>> 
>>> thanks,
>>> yeshwanth
>> 

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message