hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: Compile and run HBase 0.98 from svn?
Date Sun, 02 Mar 2014 13:24:25 GMT
Ok. I found my issue! Thanks all.

I was looking for the .tar.gz file to be created under the root directory
or under a target directory but found none of this. Finally, I found the
file under hbase-assembly/target/

So will run 0.98 on my cluster shortly ;)

Thanks all!


2014-03-02 4:52 GMT-05:00 Andrew Purtell <apurtell@apache.org>:

> I use 'mvn -DskipTests clean install package assembly:single' and get a
> workable binary jar with the right bits under lib/.
>
>
> On Sun, Mar 2, 2014 at 10:44 AM, Marcos Luis Ortiz Valmaseda <
> marcosluis2186@gmail.com> wrote:
>
> > Did you read here?
> > https://hbase.apache.org/book/build.html
> >
> >
> > 2014-03-01 21:55 GMT-04:30 Jean-Marc Spaggiari <jean-marc@spaggiari.org
> >:
> >
> > > Hi all,
> > >
> > > Any hint on the way to build and run 0.98?
> > >
> > > svn co  http://svn.apache.org/repos/asf/hbase/branches/0.98/hbase-0.98
> > > mvn clean install assembly:assembly -DskipTests -Prelease
> > >
> > > All passed.
> > >
> > > Update hbase-env hbase-site and regionservers.
> > >
> > > Distribute all the directory on 4 servers.
> > >
> > > But... something is missing. Doing that, I miss many libs, like
> > > zookeeper-3.4.5.jar.
> > >
> > > So I guess I'm not building it the right way.
> > >
> > > Can anyone point me to the right steps?
> > >
> > > Thanks,
> > >
> > > JM
> > >
> >
> >
> >
> > --
> > Marcos Ortiz Valmaseda
> > http://about.me/marcosortiz
> >
>
>
>
> --
> Best regards,
>
>    - Andy
>
> Problems worthy of attack prove their worth by hitting back. - Piet Hein
> (via Tom White)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message