hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Maven dependency for HBase 0.96
Date Thu, 27 Mar 2014 17:37:21 GMT
On Thu, Mar 27, 2014 at 6:36 AM, rakesh rakshit <ihavethepotential@gmail.com
> wrote:

> Hi St. Ack,
> Thanks for your reply. Yes I wanted to pull everything related to HBase. We
> used 0.94.5 before and the dependency looks as follows:
> <dependency>
>   <groupId>org.apache.hbase</groupId>
>   <artifactId>hbase</artifactId>
>   <version>0.94.5</version>
> </dependency>
> So, I expect that the HBase 0.96.0 dependency gets pulled exactly the same
> way.
> Please let me know if we can do that or if there is an alternate way to do
> it.

HBase was broken up into multiple maven modules in 0.96.  0.94 was made of
one maven module only.  As I understand it, you have to pick and choose the
modules you need; you can't do a blanket include (I could be wrong here; at
least, it does not currently work as you have discovered).  See the pom I
cited as an example of what is needed running a downstream application that
needs to use the hbase minicluster.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message