hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lars hofhansl <la...@apache.org>
Subject Re: Getting exceptions in fresh installment of hbase
Date Fri, 21 Mar 2014 23:52:52 GMT
Hi Vimal,

did you rebuild HBase against Hadoop 1.2.1? The released tarballs are built against Hadoop
1.0.4 and won't work with Hadoop 1.2.x or 2.x.y.


-- Lars



________________________________
 From: Vimal Jain <vkjk89@gmail.com>
To: "user@hbase.apache.org" <user@hbase.apache.org>; lars hofhansl <larsh@apache.org>

Sent: Friday, March 21, 2014 12:08 AM
Subject: Re: Getting exceptions in fresh installment of hbase
 


Hi Stack/Lars,
I configured Hbase again in pseudo distributed mode.
Again i got some exceptions which have shared in pastebin

zookeeper log - http://pastebin.com/6vgbm987
master log - http://pastebin.com/kcjpd1Zp
region log - http://pastebin.com/vmfE2HG2

There is no error in all 3 hadoop processes.
And i am sure if i restart the hbase , i will get errors like 'Region is not online: -ROOT-'
, 'Region is not online: .META'
This is the pattern i have observed.

Let me know if you want me to restart the hbase cluster and then i will attach fresh logs.

Hbase - 0.94.17 and Hadoop 1.2.1



On Fri, Mar 21, 2014 at 11:47 AM, lars hofhansl <larsh@apache.org> wrote:

I do this *all* the time, I have never seen an issue like this. So this is interesting.
>Is it possible that ZK happened to have picked a use ephemeral port? (but in that case
I would have only expected this to fail once and work the next time).
>
>-- Lars
>
>
>
>________________________________
> From: Vimal Jain <vkjk89@gmail.com>
>To: "user@hbase.apache.org" <user@hbase.apache.org>
>Sent: Thursday, March 20, 2014 11:10 PM
>Subject: Re: Getting exceptions in fresh installment of hbase
>
>
>
>Hi Stack,
>I will delete everything and reconfigure hbase from scratch.
>I will then attach logs in pastebin  if i find same issues again.
>
>
>On Fri, Mar 21, 2014 at 11:20 AM, Stack <stack@duboce.net> wrote:
>
>> Put the full logs up in pastebin.  The below seem like symptoms, not the
>> problem.
>> St.Ack
>>
>>
>> On Thu, Mar 20, 2014 at 10:12 PM, Vimal Jain <vkjk89@gmail.com> wrote:
>>
>> > Yes Stack.
>> >
>> >
>> > On Fri, Mar 21, 2014 at 9:22 AM, Stack <stack@duboce.net> wrote:
>> >
>> > > On Thu, Mar 20, 2014 at 4:19 AM, Vimal Jain <vkjk89@gmail.com> wrote:
>> > >
>> > > > Hi,
>> > > > I am configuring hbase ( 0.94.17 and hadoop 1.2.1 ) in pseudo
>> > distributed
>> > > > mode and i am getting below exceptions when starting hbase for first
>> > > time.
>> > > >
>> > > >
>> > > You started fresh?  Fresh HDFS and ZK in particular?
>> > > St.Ack
>> > >
>> > >
>> > >
>> > > > Master logs :-
>> > > >
>> > > > 1) WARN org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper: Node
>> > > > /hbase/backup-m
>> > > > asters/hbase.rummycircle.com,60000,1395314029900 already deleted,
>> and
>> > > this
>> > > > is not a retry
>> > > >
>> > > > 2) org.apache.hadoop.hbase.catalog.CatalogTracker: Failed
>> verification
>> > of
>> > > > -ROOT
>> > > > -,,0 at address=hbase.rummycircle.com,60020,1395313673569;
>> > > > org.apache.hadoop.hbase.NotServingRegionException:
>> > > > org.apache.hadoop.hbase.N
>> > > > otServingRegionException: Region is not online: -ROOT-,,0
>> > > >
>> > > > 3) org.apache.hadoop.hbase.catalog.CatalogTracker: Failed
>> verification
>> > of
>> > > > .META
>> > > > .,,1 at address=hbase.rummycircle.com,60020,1395313673569;
>> > > > org.apache.hadoop.hbase.NotServingRegionException:
>> > > > org.apache.hadoop.hbase.N
>> > > > otServingRegionException: Region is not online: .META.,,1
>> > > >
>> > > > 4) ERROR org.apache.hadoop.hbase.regionserver.metrics.SchemaMetrics:
>> > > > Inconsist
>> > > > ent configuration. Previous configuration for using table name in
>> > > metrics:
>> > > > true, new configuration: false
>> > > >
>> > > > 5) Got user-level KeeperEx
>> > > > ception when processing sessionid:0x144df32705d0000 type:delete
>> > cxid:0xc
>> > > > zxid:0x53 txntype:-1 reqpath:n/a Error Path:/hbase/backup-mast
>> > > > ers/hbase.rummycircle.com,60000,1395314029900 Error:KeeperErrorCode
>> =
>> > > > NoNode for /hbase/backup-masters/hbase.rummycircle.com,60000,1395
>> > > > 314029900
>> > > >
>> > > > 3rd and 5th ones getting repeated multiple times.
>> > > >
>> > > > Please help.
>> > > >
>> > > >
>> > > >
>> > > > --
>> > > > Thanks and Regards,
>
>> > > > Vimal Jain
>> > > >
>> > >
>> >
>> >
>> >
>> > --
>> > Thanks and Regards,
>> > Vimal Jain
>> >
>>
>
>
>
>--
>Thanks and Regards,
>Vimal Jain


-- 

Thanks and Regards,
Vimal Jain
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message