hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Questions about Hbase,please help!
Date Sat, 25 Jan 2014 16:04:02 GMT
There are two tar balls in 0.96 release.

Did you use the one named 0.96.0-hadoop2 ?


On Sat, Jan 25, 2014 at 7:29 AM, <cao.wei56@zte.com.cn> wrote:

> Dear Sirs:
>     When I installing Hbase,I met a problem.Could you please help me?The
> hadoop version is hadoop-2.2.0 and hbase version is hbase-0.96.0.
>     After I run start-hbase.sh on master,the datanode regionserver's log
> shows the following errors.
>
> 2014-01-24 17:03:43,437 INFO  [main] util.ServerCommandLine:
> vmInputArguments=[-Dproc_regionserver, -XX:OnOutOfMemoryError=kill -9 %p,
> -Xmx1000m, -XX:+UseConcMarkSweepGC,
> -Dhbase.log.dir=/home/hadoop/hbase-0.96.0-hadoop2/bin/../logs,
> -Dhbase.log.file=hbase-hadoop-regionserver-ubuntu23.log,
> -Dhbase.home.dir=/home/hadoop/hbase-0.96.0-hadoop2/bin/..,
> -Dhbase.id.str=hadoop, -Dhbase.root.logger=INFO,RFA,
> -Dhbase.security.logger=INFO,RFAS]
> 2014-01-24 17:03:43,537 DEBUG [main] regionserver.HRegionServer:
> regionserver/ubuntu23/10.45.33.23:60020 HConnection server-to-server
> retries=350
> 2014-01-24 17:03:43,812 INFO  [main] ipc.RpcServer:
> regionserver/ubuntu23/10.45.33.23:60020: started 10 reader(s).
> 2014-01-24 17:03:43,903 INFO  [main] impl.MetricsConfig: loaded properties
> from hadoop-metrics2-hbase.properties
> 2014-01-24 17:03:43,983 INFO  [main] impl.MetricsSystemImpl: Scheduled
> snapshot period at 10 second(s).
> 2014-01-24 17:03:43,983 INFO  [main] impl.MetricsSystemImpl: HBase metrics
> system started
> 2014-01-24 17:03:44,060 ERROR [main]
> regionserver.HRegionServerCommandLine: Region server exiting
> java.lang.RuntimeException: Failed construction of Regionserver: class
> org.apache.hadoop.hbase.regionserver.HRegionServer
>         at
>
> org.apache.hadoop.hbase.regionserver.HRegionServer.constructRegionServer(HRegionServer.java:2296)
>         at
>
> org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.start(HRegionServerCommandLine.java:61)
>         at
>
> org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.run(HRegionServerCommandLine.java:85)
>         at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>         at
>
> org.apache.hadoop.hbase.util.ServerCommandLine.doMain(ServerCommandLine.java:126)
>         at
>
> org.apache.hadoop.hbase.regionserver.HRegionServer.main(HRegionServer.java:2311)
> Caused by: java.lang.reflect.InvocationTargetException
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> Method)
>         at
>
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
>         at
>
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
>         at
>
> org.apache.hadoop.hbase.regionserver.HRegionServer.constructRegionServer(HRegionServer.java:2294)
>         ... 5 more
> Caused by: java.lang.NoClassDefFoundError:
> org/apache/hadoop/util/PlatformName
>         at
>
> org.apache.hadoop.security.UserGroupInformation.getOSLoginModuleName(UserGroupInformation.java:303)
>         at
>
> org.apache.hadoop.security.UserGroupInformation.<clinit>(UserGroupInformation.java:348)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
>
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>         at
>
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:606)
>         at org.apache.hadoop.hbase.util.Methods.call(Methods.java:39)
>         at org.apache.hadoop.hbase.security.User.call(User.java:414)
>         at org.apache.hadoop.hbase.security.User.callStatic(User.java:404)
>         at org.apache.hadoop.hbase.security.User.access$200(User.java:48)
>
>
>     I search the information on google,but I couldn't find any useful
> informations.Could you please give me some advices to solve this problem.
>     Thanks a lot!
>     Best regards!
>     CaoWei
>
>
>
>
>
>
>
>
> --------------------------------------------------------
> ZTE Information Security Notice: The information contained in this mail
> (and any attachment transmitted herewith) is privileged and confidential
> and is intended for the exclusive use of the addressee(s).  If you are not
> an intended recipient, any disclosure, reproduction, distribution or other
> dissemination or use of the information contained is strictly prohibited.
>  If you have received this mail in error, please delete it and notify us
> immediately.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message