hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From daidong <daidon...@gmail.com>
Subject Re: HBase MapReduce with setup function problem
Date Mon, 27 Jan 2014 19:56:08 GMT
Dear Ted, Thanks very much for your reply!

Yes. MultiTableInputFormat may work here, but i still want to know how to
connect a hbase table inside MapReduce applications. Because i may need
also write to tables inside map function.

Do you know why previous mr application does not work? Because the wrong
configuration instance? Any suggestion will be great for me! Thanks!

- Dong


2014-01-27 Ted Yu <yuzhihong@gmail.com>

> Have you considered using MultiTableInputFormat ?
>
> Cheers
>
>
> On Mon, Jan 27, 2014 at 9:14 AM, daidong <daidongly@gmail.com> wrote:
>
> > Dear all,
> >
> >   I am writing a MapReduce application processing HBase table. In each
> map,
> > it needs to read data from another HBase table, so i use the 'setup'
> > function to initialize the HTable instance like this:
> >
> > @Override
> >
> >     public void setup(Context context){
> >
> >       Configuration conf = HBaseConfiguration.create();
> >
> >       try {
> >
> >        centrals = new HTable(conf, "central".getBytes());
> >
> >       } catch (IOException e) {
> >
> >       }
> >
> >       return;
> >
> >     }
> >
> > But, when i run this mapreduce application, it is always stay in 0%,0%.
> And
> > the map phase is always under initializing, does not progress. I have
> > googled it, but still do not have any ideas.
> >
> > P.S. I use hadoop-1.1.2 and Hbase-0.96.
> >
> > Thanks!
> >
> > - Dong
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message