hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ramkrishna vasudevan <ramkrishna.s.vasude...@gmail.com>
Subject Re: Region server logs not getting updated..
Date Tue, 21 Jan 2014 06:38:27 GMT
>>Now the issue is resolved.
Nice.. and Thank you for the update.


On Tue, Jan 21, 2014 at 12:06 PM, Sandeep B A <sandythebond@gmail.com>wrote:

> Hi,
>
> @ramkrishna: Log level currently set is INFO.
> When it was last updated, i see INFO level logs.
>
> @Bharath: From cloudera manager there was no overriden logging.
>
> While trying on coprocessors, we added few jars, when i removed those,
> region server logs started getting updated.
> There was a logging jar also which was placed as part of this.
> That was causing this issue.
> Now i will re iterate and look through all the jars and figure out how to
> do it without affecting the existing functionality of hbase.
>
> Thanks all for your help, Now the issue is resolved.
>
> Thanks & Regards,
> Sandeep B A
>  Hi,
>
> You can check if you have any overrides for log4j from CM (search for
> "log4j regionserver" in hbase configs from CM UI). Also check the logging
> threshold as Ramkrishna suggested.
>
> - Bharath
>
>
> On Tue, Jan 21, 2014 at 9:40 AM, Sandeep B A <sandythebond@gmail.com>
> wrote:
>
> > Hi Ted,
> > Yes, region servers are up and running.
> > I scan I get the rows but nothing gets updated in the logs.
> > I issued major compaction and nothing gets updated in the logs.
> > I have also tried to give new location to the logs directory but there
> also
> > not updating.
> > I verified all the permission are fine and and disk is also not full.
> >
> > Please suggest how do I proceed further?
> >
> > @all, has any one observed this scenario before? Its kind of blocker to
> me
> > now :-( not able to proceed :-(
> >  On Jan 20, 2014 10:51 PM, "Ted Yu" <yuzhihong@gmail.com> wrote:
> >
> > > Is this region server still serving requests ?
> > > You can scan one of the regions hosted by this server, or issue
> > compaction
> > > request to such region to see if there is new log showing up.
> > >
> > > Cheers
> > >
> > >
> > > On Mon, Jan 20, 2014 at 2:08 AM, Sandeep B A <sandythebond@gmail.com>
> > > wrote:
> > >
> > > > Hi Ted,
> > > > Sorry for the late reply.
> > > > The log location which was listed using ps command,  I checked. Thing
> > is
> > > > after some time, looks like logs not getting updated... In the logs
> > also
> > > > not much information why region server stopped updating logs.. How do
> I
> > > > make region server to start updating logs...?
> > > >
> > > > Thanks for the help.
> > > > Thanks and Regards
> > > > Sandeep  B A
> > > > On Jan 17, 2014 7:30 PM, "Ted Yu" <yuzhihong@gmail.com> wrote:
> > > >
> > > > > On the machine where region server runs, you can use ps command to
> > find
> > > > > the command line associated with region server process.
> > > > >
> > > > > The log directory would be shown there.
> > > > >
> > > > > Cheers
> > > > >
> > > > > On Jan 17, 2014, at 4:00 AM, Sandeep B A <sandythebond@gmail.com>
> > > wrote:
> > > > >
> > > > > > Hi All....
> > > > > > Currently im facing the issue where region server not updating
> the
> > > > logs.
> > > > > I
> > > > > > don't know where to check nor how to proceed further.
> > > > > >
> > > > > > I'm using cloudera manager to manage hbase cluster..
> > > > > > Current hbase version in use 0.94.6-CDH4.5.0
> > > > > >
> > > > > > If i check from master status page, All the region servers are
up
> > and
> > > > > > running and any get operations is successful.
> > > > > > Kindly can any one help me to figure out how to get the region
> > server
> > > > > > logs(*.log.out).
> > > > > >
> > > > > > Thanks for the help in advance.
> > > > > >
> > > > > > Thanks and Regards
> > > > > > Sandeep B A
> > > > >
> > > >
> > >
> >
>
>
>
> --
> Bharath Vissapragada
> <http://www.cloudera.com>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message