hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "LEI Xiaofeng" <le...@ihep.ac.cn>
Subject Re: Re: hbase read performance tuning failed
Date Wed, 08 Jan 2014 01:23:16 GMT
I use "scannerOpenWithPrefix" func to get my scanner and use "scannerGetList(rowResults, scanner,100)"
func to get rows. I can only get about 5K records per second. But my exception is at least
220K records per second. 


> -----原始邮件-----
> 发件人: "Haosong Huang" <haosdent@gmail.com>
> 发送时间: 2014年1月7日 星期二
> 收件人: user@hbase.apache.org
> 抄送: 
> 主题: Re: hbase read performance tuning failed
> 
> >but the scan performance is poor.
> 
> Did you set start row and end row in the Scan? Besides, if the random read
> performance of your cluster is ok, maybe smallscan could help you.
> HBASE-9488 <https://issues.apache.org/jira/browse/HBASE-9488>
> 
> 
> On Tue, Jan 7, 2014 at 3:06 PM, LEI Xiaofeng <leixf@ihep.ac.cn> wrote:
> 
> > Hi,
> > I am running hbase-0.94.6-cdh4.5.0 and set up a cluster of 5 nodes. The
> > random read performance is ok, but the scan performance is poor.
> > I tried to increase "hbase.client.scanner.caching" to 100 to promote the
> > scan performance but it made  no difference. And when I tried to make
> > smaller blocks by setting "BLOCKSIZE" when created tables to get better
> > random read performance it made no difference too.
> > So, I am wondering if anyone could give some advice to solve this problem.
> >
> >
> >
> > Thanks
> >
> 
> 
> 
> -- 
> Best Regards,
> Haosdent Huang


Mime
View raw message