hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: hbase config problem
Date Fri, 27 Dec 2013 18:14:40 GMT
Thanks for sharing the files.

So 2 things.

first, regarding the hosts file. You have twice the same name but with 2
different IPs:
127.0.0.1       zenlinux.localdomain zenlinux
127.0.0.1       localhost.localdomain locahost
192.168.1.81 zenlinux.localdomain zenlinux

Please remove the 1st line.

2nd, in your hbase-site.xml can you please try without those 2 properties
set? Just keep it empty. It will use the /tmp directory.

Thanks,

JM


2013/12/27 Gerald Klein <jk@zognet.com>

> OK here they are first is hbase-env.sh
>
> http://pastebin.com/KPaw9aaE
>
> second hbase-site.xml
>
> http://pastebin.com/WZixuTas
>
> third hosts file
>
> http://pastebin.com/dLFi7gcN
>
>
> thanks again
>
> I am not worried about the password locally I just type it in, this is fine
> for learning it
>
>
>
>
> On Fri, Dec 27, 2013 at 11:34 AM, Jean-Marc Spaggiari <
> jean-marc@spaggiari.org> wrote:
>
> > Attachements doesn't work on the mailing list :( You can paste them on
> > pastebin or past the content of the scripts on your email directly.
> >
> > Have you been able to configure the passwordless?
> >
> > Also, you are trying with 0.96.0, right? Can you try with 0.96.1.1
> instead?
> > http://www.apache.org/dyn/closer.cgi/hbase/
> >
> > JM
> >
> >
> > 2013/12/27 Gerald Klein <jk@zognet.com>
> >
> > > OK here it is and thanks a lot for taking the time.
> > >
> > >
> > > On Fri, Dec 27, 2013 at 11:15 AM, Jean-Marc Spaggiari <
> > > jean-marc@spaggiari.org> wrote:
> > >
> > >> Can you share your config files?
> > >> hbase-env.sh
> > >> hosts
> > >> hbase-site.xml
> > >>
> > >> Are you able to passwordless ssh in the same host? Like ssh MYHOST
> does
> > it
> > >> ask for a password?
> > >>
> > >> If so, can you configure it password less?
> > >>
> > >> to create the key: ssh-keygen -t rsa
> > >> To install: ssh-copy-id -i ~/.ssh/id_rsa.pub
> > your_user_name@your_host_name
> > >>
> > >> JM
> > >>
> > >>
> > >> 2013/12/27 Gerald Klein <jk@zognet.com>
> > >>
> > >> > Yes I have added it to the conf/hbase-env.sh file in the last email
> > >> when it
> > >> > initially failed that test, I currently have it pointed to
> > >> > /opt/oracle-jdk-bin-1.7.0.45
> > >> > which is where Gentoo has it installed.
> > >> >
> > >> >
> > >> >
> > >> >
> > >> >
> > >> > On Fri, Dec 27, 2013 at 10:48 AM, Jean-Marc Spaggiari <
> > >> > jean-marc@spaggiari.org> wrote:
> > >> >
> > >> > > Have you modified any of the files into conf/ ?
> > >> > >
> > >> > > Please add your JAVA_HOME setting into conf/hbase-env.sh and
> retry.
> > >> > >
> > >> > > The password issue is related to the passwordless setting, but
it
> > >> should
> > >> > > not be required for the standalone version. We will look at that
> > after
> > >> > you
> > >> > > try again ;)
> > >> > >
> > >> > > JM
> > >> > >
> > >> > >
> > >> > > 2013/12/27 Gerald Klein <jk@zognet.com>
> > >> > >
> > >> > > > Thanks for the help, I unset all vars and made sure that
the
> > >> JAVA_HOME
> > >> > > was
> > >> > > > set in .bashrc, Same errors but now JAVA_HOME not set as
below:
> > >> > > >
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.util.HBaseConfTool
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.zookeeper.ZKServerTool
> > >> > > > starting master, logging to
> > >> > > >
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> /root/Software/hbase-gz/hbase-0.96.0/bin/../logs/hbase-root-master-zenlinux.out
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.master.HMaster
> > >> > > > Password:
> > >> > > > localhost:
> > >> > > >
> > >> >
> > +======================================================================+
> > >> > > > localhost: |      Error: JAVA_HOME is not set and Java could
not
> > be
> > >> > found
> > >> > > >       |
> > >> > > > localhost:
> > >> > > >
> > >> >
> > +----------------------------------------------------------------------+
> > >> > > > localhost: | Please download the latest Sun JDK from the
Sun
> Java
> > >> web
> > >> > > site
> > >> > > >        |
> > >> > > > localhost: |       > http://java.sun.com/javase/downloads/
<
> > >> > > >        |
> > >> > > > localhost: |
> > >> > > >        |
> > >> > > > localhost: | HBase requires Java 1.6 or later.
> > >> > > >        |
> > >> > > > localhost: | NOTE: This script will find Sun Java whether
you
> > >> install
> > >> > > using
> > >> > > > the   |
> > >> > > > localhost: |       binary or the RPM based installer.
> > >> > > >       |
> > >> > > > localhost:
> > >> > > >
> > >> >
> > +======================================================================+
> > >> > > >
> > >> > > > So I set JAVA_HOME in hbase-env.sh, but I still get the
> following
> > >> > > >
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.util.HBaseConfTool
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.zookeeper.ZKServerTool
> > >> > > > starting master, logging to
> > >> > > >
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> /root/Software/hbase-gz/hbase-0.95.2/bin/../logs/hbase-root-master-zenlinux.out
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.master.HMaster
> > >> > > > Password:
> > >> > > > localhost: starting regionserver, logging to
> > >> > > >
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> /root/Software/hbase-gz/hbase-0.95.2/bin/../logs/hbase-root-regionserver-zenlinux.out
> > >> > > > localhost: Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.regionserver.HRegionServer
> > >> > > >
> > >> > > > then I forced a domain name via hostname and still got the
> > following
> > >> > > >
> > >> > > >
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.util.HBaseConfTool
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.zookeeper.ZKServerTool
> > >> > > > starting master, logging to
> > >> > > >
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> /root/Software/hbase-gz/hbase-0.96.0/bin/../logs/hbase-root-master-zenlinux.localdomain.com.out
> > >> > > > Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.master.HMaster
> > >> > > > Password:
> > >> > > > localhost: starting regionserver, logging to
> > >> > > >
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> /root/Software/hbase-gz/hbase-0.96.0/bin/../logs/hbase-root-regionserver-zenlinux.localdomain.com.out
> > >> > > > localhost: Error: Could not find or load main class
> > >> > > > org.apache.hadoop.hbase.regionserver.HRegionServer
> > >> > > >
> > >> > > >
> > >> > > > I appreciate any help with this, I don't usually experience
a
> > setup
> > >> > > problem
> > >> > > > like this.
> > >> > > >
> > >> > > > thanks
> > >> > > >
> > >> > > >
> > >> > > >
> > >> > > > On Fri, Dec 27, 2013 at 8:48 AM, Jean-Marc Spaggiari <
> > >> > > > jean-marc@spaggiari.org> wrote:
> > >> > > >
> > >> > > > > Hi Gerald,
> > >> > > > >
> > >> > > > > The easiest way to test HBase locally is:
> > >> > > > > 1) Download the tar.gz
> > >> > > > > 2) Ungzip it.
> > >> > > > > 3) Make sure host file contains FQDN assign to local
IP
> address
> > >> (and
> > >> > > not
> > >> > > > > 127.0.0.1)
> > >> > > > > 4) define JAVA_HOME to point to you Sun JDK
> > >> > > > > 5) bin/start-hbase.sh
> > >> > > > >
> > >> > > > > Don't change anything, don't set any other variable,
don't do
> > >> > anything.
> > >> > > > > Just those 5 simple steps. Then you should have a standalone
> > >> version
> > >> > > > > running.
> > >> > > > >
> > >> > > > > JM
> > >> > > > >
> > >> > > > >
> > >> > > > > 2013/12/27 Gerald Klein <jk@zognet.com>
> > >> > > > >
> > >> > > > > > hi I have been attempting to learn hbase and have
been
> unable
> > to
> > >> > get
> > >> > > a
> > >> > > > > > local copy running, it comes back with"could not
find or
> load
> > >> main
> > >> > > > class
> > >> > > > > > org.apache.hadoop.hbase.util.HBaseConfTool" and
"could not
> > find
> > >> or
> > >> > > load
> > >> > > > > > main class org.apache.hadoop.hbase.zookeeper.ZKServerTool"
> and
> > >> > "culd
> > >> > > > not
> > >> > > > > > find or load main class
> > org.apache.hadoop.hbase.master.HMaster"
> > >> I
> > >> > > have
> > >> > > > > > tried adding stuff to the config HBASE_CLASSPATH
but nothing
> > >> seems
> > >> > to
> > >> > > > get
> > >> > > > > > rid of the error, I also grepped the directories
from the
> > >> install
> > >> > > > package
> > >> > > > > > and could not find the class that they are looking
for,
> anyone
> > >> have
> > >> > > an
> > >> > > > > idea
> > >> > > > > > of what this is? thanks
> > >> > > > > >
> > >> > > > > > --
> > >> > > > > >
> > >> > > > > > Gerald Klein DBA
> > >> > > > > >
> > >> > > > > > ContactMe@geraldklein.com
> > >> > > > > >
> > >> > > > > > www.geraldklein.com <http://geraldklein.com/>
> > >> > > > > >
> > >> > > > > > geraldklein.wordpress.com
> > >> > > > > >
> > >> > > > > > jk@zognet.com
> > >> > > > > >
> > >> > > > > > 708-599-0352
> > >> > > > > >
> > >> > > > > >
> > >> > > > > > Arch Awesome, Ranger & Vim the coding triple
threat.
> > >> > > > > >
> > >> > > > > > Linux registered user #548580
> > >> > > > > >
> > >> > > > > > Brought to you by the Amish Mafia
> > >> > > > > >
> > >> > > > >
> > >> > > >
> > >> > > >
> > >> > > >
> > >> > > > --
> > >> > > >
> > >> > > > Gerald Klein DBA
> > >> > > >
> > >> > > > ContactMe@geraldklein.com
> > >> > > >
> > >> > > > www.geraldklein.com <http://geraldklein.com/>
> > >> > > >
> > >> > > > geraldklein.wordpress.com
> > >> > > >
> > >> > > > jk@zognet.com
> > >> > > >
> > >> > > > 708-599-0352
> > >> > > >
> > >> > > >
> > >> > > > Arch Awesome, Ranger & Vim the coding triple threat.
> > >> > > >
> > >> > > > Linux registered user #548580
> > >> > > >
> > >> > > > Brought to you by the Amish Mafia
> > >> > > >
> > >> > >
> > >> >
> > >> >
> > >> >
> > >> > --
> > >> >
> > >> > Gerald Klein DBA
> > >> >
> > >> > ContactMe@geraldklein.com
> > >> >
> > >> > www.geraldklein.com <http://geraldklein.com/>
> > >> >
> > >> > geraldklein.wordpress.com
> > >> >
> > >> > jk@zognet.com
> > >> >
> > >> > 708-599-0352
> > >> >
> > >> >
> > >> > Arch Awesome, Ranger & Vim the coding triple threat.
> > >> >
> > >> > Linux registered user #548580
> > >> >
> > >> > Brought to you by the Amish Mafia
> > >> >
> > >>
> > >
> > >
> > >
> > > --
> > >
> > > Gerald Klein DBA
> > >
> > > ContactMe@geraldklein.com
> > >
> > > www.geraldklein.com <http://geraldklein.com/>
> > >
> > > geraldklein.wordpress.com
> > >
> > > jk@zognet.com
> > >
> > > 708-599-0352
> > >
> > >
> > > Arch Awesome, Ranger & Vim the coding triple threat.
> > >
> > > Linux registered user #548580
> > >
> > > Brought to you by the Amish Mafia
> > >
> > >
> >
>
>
>
> --
>
> Gerald Klein DBA
>
> ContactMe@geraldklein.com
>
> www.geraldklein.com <http://geraldklein.com/>
>
> geraldklein.wordpress.com
>
> jk@zognet.com
>
> 708-599-0352
>
>
> Arch Awesome, Ranger & Vim the coding triple threat.
>
> Linux registered user #548580
>
> Brought to you by the Amish Mafia
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message