hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mrudula Madiraju <mrudulamadir...@yahoo.com>
Subject Re: Consequent deletes more than ~256 rows not working
Date Tue, 03 Dec 2013 12:20:32 GMT
The issue is with my code. Something to do with cache that I was using to store the rowkeys.

Thanks Anyway!


On Tuesday, 3 December 2013 4:34 AM, Ted Yu <yuzhihong@gmail.com> wrote:
Which HBase release are you using ?

In your while loop, you used the same set of row keys for each attempt ?


On Sun, Dec 1, 2013 at 11:28 PM, Mrudula Madiraju <mrudulamadiraju@yahoo.com> wrote:

>I have a simple hbase table of approx. 1000 rows.
>If I invoke the htable.delete() on this table in a while loop - it doesn't throw any
error or exception.
>But at the end of operation - I see that it has actually deleted only about 256 rows.
>Repeating the operation deletes another 256 or so. And finally after 3 or 4 runs , all
rows finally get deleted.
>This is true of htable.batch API or even htable.delete API.
>Have tried changing ulimit/nproc settings, invoking flush, setting autocommit, invoking
major Compact
>Also waited out - That is to see if after 5 minutes of first run delete will complete
in background. Nothing works.
>Searched the mailing list and see that there are threads on delete followed by put not
working etc.
>But this is a different case.
>Anyone who knows what's happening? Looking forward to any pointers!
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message