hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinay Kashyap <vinu.k...@gmail.com>
Subject Re: HBase - number of regionserver used
Date Wed, 13 Nov 2013 01:40:26 GMT
Andrea

Looks like you might have to consider creating the table using pre splits..
In order to split the load to all the region servers, you have to decide
the key splits and use the splits while creating the table. You can use
hbase shell command to specify the splits.

Pre split regions shows very good performance for hbase load with YCSB..

Thanks and regards
Vinay Kashyap
On Nov 12, 2013 2:20 AM, "Andrea" <andrea.gandini.89@gmail.com> wrote:

> Hi, I have HBase above Hadoop with one master node, one zookeeper node and
> four regionservers. When I turn up everything, on two nodes (or sometime
> the
> same node) are created the tables .META. and -ROOT- and then I create a
> table
> called 'usertable' which goes to another random node.
>
> Now, when i test the system (with YCSB tool), i notice that only the
> regionserver which contain the table 'usertable' works and split the
> region.
> So it means that only one node works? There's no way to split the load work
> on the other nodes?
>
> And further more, when i try to load a lot of rows, it crashes and I am not
> able to restore my table, and I have to rebuilt the entire system from
> zero.
>
> Thank you in advance for your time!
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message