hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandeep L <sandeepvre...@outlook.com>
Subject RE: HBase wont responding when one region server goes down
Date Tue, 29 Oct 2013 03:36:47 GMT
@Jean-mar 
We are using HBase-0.94.1 with Hadoop-1.0.2.We have 15 Region servers, 5 Zookeepers, 1 master,
3 backup masters and & 18 Dtatnodes.Our Java version is "jdk1.7.0_04"
The issue is whenever a region server is down scan/get is not working.
Thanks,Sandeep.

> From: jean-marc@spaggiari.org
> Date: Mon, 28 Oct 2013 15:55:31 -0400
> Subject: Re: HBase wont responding when one region server goes down
> To: user@hbase.apache.org
> 
> Hi Sandeep,
> 
> Do you have more information regarding your cluster? Number of nodes,
> hadoop version, what is "not responding", etc.?
> 
> Thanks,
> 
> JM
> 
> 
> 2013/10/28 Asaf Mesika <asaf.mesika@gmail.com>
> 
> > If your query (scan) needs a region on the failed region server, the client
> > will fail and silently retry about 10 times. The sleep time increase as
> > each retry fails and can reach 10min. On the server side, the master takes
> > 3min to realize the RS failed thus issue a region move, which might take a
> > few minutes, which together explain the 10min query failure period
> >
> > On Monday, October 28, 2013, Sandeep L wrote:
> >
> > > Hi,
> > > We are using HBase 0.94.1.
> > > We are facing a strange issue form long time not at got any proper
> > > solution.
> > > Here is the issue:Whenever one region server in cluster goes down, whole
> > > HBase wont respond for some time (around 5 to 10 minutes).We are unable
> > to
> > > get any clue about the issue.
> > >
> > > Can some help us to resolve this issue.
> > >
> > > Thanks,Sandeep.
> >
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message