hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sznajder ForMailingList <bs4mailingl...@gmail.com>
Subject Re: Connecting to a remote distributed HBASE env.
Date Sun, 15 Sep 2013 13:32:18 GMT
 I am using Hbase 0.90.4

Benjamin


On Sun, Sep 15, 2013 at 4:31 PM, Sznajder ForMailingList <
bs4mailinglist@gmail.com> wrote:

> Hi
>
> When I am connecting from server4 via my java code:
> (again, hbase runs on server1, server2 and server3)
>
>
> I am getting the following:
>
>      [java] Exception in thread "main" java.lang.RuntimeException:
> org.apache.gora.util.GoraException: java.lang.RuntimeException:
> org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able to
> connect to ZooKeeper but the connection closes immediately. This could be a
> sign that the server has too many connections (30 is the default). Consider
> inspecting your ZK server logs for that error and then make sure you are
> reusing HBaseConfiguration as often as you can. See HTable's javadoc for
> more information.
>      [java]     at
> com.ibm.hrl.crawldb.CrawlDataBase.<init>(CrawlDataBase.java:43)
>      [java]     at
> com.ibm.hrl.main.CrawlQueueMain.main(CrawlQueueMain.java:72)
>      [java] Caused by: org.apache.gora.util.GoraException:
> java.lang.RuntimeException:
> org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able to
> connect to ZooKeeper but the connection closes immediately. This could be a
> sign that the server has too many connections (30 is the default). Consider
> inspecting your ZK server logs for that error and then make sure you are
> reusing HBaseConfiguration as often as you can. See HTable's javadoc for
> more information.
>
>
>
> On Sun, Sep 15, 2013 at 3:34 PM, Jean-Marc Spaggiari <
> jean-marc@spaggiari.org> wrote:
>
>> Also, I will add to Ted:
>> what have you tried so far?
>>
>> JM
>>
>>
>> 2013/9/15 Ted Yu <yuzhihong@gmail.com>
>>
>> > Have you read http://hbase.apache.org/book.html#zookeeper ?
>> >
>> > What HBase version are you using ?
>> >
>> > Can you pastebin the error(s) you encountered ?
>> >
>> > Thanks
>> >
>> > On Sep 15, 2013, at 1:26 AM, Sznajder ForMailingList <
>> > bs4mailinglist@gmail.com> wrote:
>> >
>> > > Hi
>> > >
>> > > I defined a distributed HBASE environment on a cluster of three
>> servers
>> > > server1
>> > > server2
>> > > server3
>> > >
>> > > I would like to run a program using this HBASE from a fourth server :
>> > > server4
>> > >
>> > > I am connecting to HBASE using GORA.
>> > > However, I do not succeed to "tell" the program to connect by remote
>> to
>> > the
>> > > hbase quorum...
>> > >
>> > > Is it possible?
>> > >
>> > > Thanks
>> > >
>> > > Benjamin
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message