hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Bertozzi <theo.berto...@gmail.com>
Subject Re: export snapshot of cloned table fails
Date Mon, 30 Sep 2013 13:55:20 GMT
The input name looks wrong, not an hfileLink.
How that was created?
could you dump the snapshots files with hbase
org.apache.hadoop.hbase.SnapshotInfo -snapshot NAME -files

Matteo



On Mon, Sep 30, 2013 at 2:36 PM, Siddharth Karandikar <
siddharth.karandikar@gmail.com> wrote:

> Hi,
>
> I have reached a situation where good old ExportSnapshot fails
>
> Here is what I am doing
>
> 1) Create table MT2
> 2) Take a snapshot of MT2 -> MT2SS1
> 3) Export MT2SS1 - works
>
> 4) Drop MT2, delete MT2SS1 from source system
> 5) Export back (import) MT2SS1 - works
>
> 6) Clone a table using MT2SS1 -> CMT2
> 7) Take a snapshot of CMT2 -> CMT2SS1
> 8) Export CMT2SS1 - FAILS
>
> Though the steps look complex, I feel, it is going to be very common
> to take snapshot of cloned (restored?) table and export that snapshot.
>
> Here is the whole output of ExportSnapshot - http://pastebin.com/N1f0Kg1a
>
>
> I think  storeFile (..) in SnapshotReferenceUtil.visitReferencedFiles
> is creating a path like
>
> "f1/CMT2=95d51af133141274fe2f0a9da79247cb-MT2=d1bcc79d7e81c481c287cb1b7f6d78e2-9b57efdf5219495ebd15d0e0b227007c"
> which is making it fail later.
>
>
> Thanks,
> Siddharth
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message