hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lukas.weibel@bluewin.ch" <lukas.wei...@bluewin.ch>
Subject Running HBase Client in WebSphere Application Server
Date Tue, 17 Sep 2013 14:06:48 GMT




Hello All,

Has anyone experience  in using HBase (Client) in WebSphere (8.0)? My application is processing
messages from a MDB
an writes them into a HBase Cluster. For testing this, I have used TomEE and everything worked
perfectly.
But now in the production environment using WebSphere Application Server, I have some problems.

 

First the login makes some problems:

 

Caused by: javax.security.auth.login.LoginException: java.lang.NullPointerException
        bm.security.auth.module.LinuxLoginModuleat com.ibm.security.auth.module.LinuxLoginModule.login(LinuxLoginModule.java:165)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
        at java.lang.reflect.Method.invoke(Method.java:611)
        at javax.security.auth.login.LoginContext.invoke(LoginContext.java:795)
        at javax.security.auth.login.LoginContext.access$000(LoginContext.java:209)
        at javax.security.auth.login.LoginContext$5.run(LoginContext.java:732)
        at java.security.AccessController.doPrivileged(AccessController.java:314)
        at javax.security.auth.login.LoginContext.invokeCreatorPriv(LoginContext.java:729)
        at javax.security.auth.login.LoginContext.login(LoginContext.java:599)
        at org.apache.hadoop.security.UserGroupInformation.getLoginUser(UserGroupInformation.java:675)

 

 

Secondly and more scary is my second problem:

 

ACWA0022I: In this particular case, a request was made to use the WorkArea service outside
the lifecycle of a valid container (e.g. EJB/Web) which is not allowed by the WorkArea service.
[9/17/13 15:10:03:995 CEST] 00000055 SystemOut     O    at com.ibm.ws.workarea.UserWorkAreaServerImpl.begin(UserWorkAreaServerImpl.java:299)
[9/17/13 15:10:03:995 CEST] 00000055 SystemOut     O    at ch.css.cesar.base.log4j.WebSphereLogContext.getProperty(WebSphereLogContext.java:121)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at ch.css.cesar.base.log4j.LogContextManager.getProperty(LogContextManager.java:226)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at ch.css.cesar.base.log4j.DefaultLogInterceptor.preLog(DefaultLogInterceptor.java:77)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at ch.css.cesar.base.log4j.CSSLogger.callAppenders(CSSLogger.java:49)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.log4j.Category.forcedLog(Category.java:391)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.log4j.Category.log(Category.java:856)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.slf4j.impl.Log4jLoggerAdapter.debug(Log4jLoggerAdapter.java:209)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.zookeeper.ClientCnxn$SendThread.readResponse(ClientCnxn.java:815)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.zookeeper.ClientCnxnSocketNIO.doIO(ClientCnxnSocketNIO.java:94)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:355)
[9/17/13 15:10:03:996 CEST] 00000055 SystemOut     O    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)

 

Has anyone already seen those problems?

 

Thanks,
Lukas


 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message