hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mrudula Madiraju <mrudulamadir...@yahoo.com>
Subject Re: Get on a row with multiple columns
Date Wed, 14 Aug 2013 06:03:41 GMT
Thanks for the response, Anoop.

On hbase 94.3 - I tried the code given in this API example documentation 
 http://hbase.apache.org/0.94/apidocs/org/apache/hadoop/hbase/coprocessor/example/BulkDeleteProtocol.html

And it was throwing
Tue Aug 13 09:26:55 PDT 2013, org.apache.hadoop.hbase.ipc.ExecRPCInvoker$1@2a862a86, org.apache.hadoop.ipc.RemoteException:org.apache.hadoop.hbase.ipc.HBaseRPC$UnknownProtocolException:org.apache.hadoop.hbase.ipc.HBaseRPC$UnknownProtocolException:
No matching handler for protocol org.apache.hadoop.hbase.coprocessor.example.BulkDeleteProtocol
in region hb1,,1376384424873.766e3ebcec45cbbbabfaee06012866a1.
    at org.apache.hadoop.hbase.regionserver.HRegion.exec(HRegion.java:5070)
    at org.apache.hadoop.hbase.regionserver.HRegionServer.execCoprocessor(HRegionServer.java:3632)


Realize now that I also needed to explicitly load the coprocessor implementation class (BulkDeleteEndpoint)
even though its a system coprocessor through hbase-site.xml.. .https://blogs.apache.org/hbase/entry/coprocessor_introduction..

It works now.


Regards,
Mrudula
Reduce,Recycle,Reuse!!!


________________________________
 From: Anoop John <anoop.hbase@gmail.com>
To: user@hbase.apache.org; Mrudula Madiraju <mrudulamadiraju@yahoo.com> 
Sent: Wednesday, 14 August 2013 10:33 AM
Subject: Re: Get on a row with multiple columns
 


You mean BulkDeleteProtocol?
 
Can u paste the trace of the exception that u r getting? Near by logs..
 
-Anoop-


On Wed, Aug 14, 2013 at 9:22 AM, Mrudula Madiraju <mrudulamadiraju@yahoo.com> wrote:

Hi Varun,
>I tried BulkDeletePoint and it is giving me an UnsupportedProtocolException - no handler
to support protocol. I am in Hbase 94.3. Can you help out - is this something you facedtoo?
>
> 
>Regards,
>Mrudula
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message