hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavan Sudheendra <pavan0...@gmail.com>
Subject Re: Trying to run HBase in standalone and not able to access Java API! Desperate help needed.
Date Tue, 16 Jul 2013 14:44:46 GMT
Jean, I'm getting a whole bunch of errors if i try your method!
I don't why i'm the only one who's encountering all this type of errors ..

On Tue, Jul 16, 2013 at 6:07 PM, Jean-Marc Spaggiari
<jean-marc@spaggiari.org> wrote:
> Sure!
>
> Here is the /etc/hosts file from my "hbasetest" server where I run
> PerformanceEvaluation tests on a standalone HBase:
> jmspaggi@hbasetest:~$ cat /etc/hosts
> 127.0.0.1       localhost
> 192.168.23.105    hbasetest
>
> # The following lines are desirable for IPv6 capable hosts
> ::1 localhost ip6-localhost ip6-loopback
> fe00::0 ip6-localnet
> ff00::0 ip6-mcastprefix
> ff02::1 ip6-allnodes
> ff02::2 ip6-allrouters
> ff02::3 ip6-allhosts
>
>
> As you can see, keep it simple ;)
>
> 192.168.23.105 is the local IP;
> root@hbasetest:/home/jmspaggi# ifconfig eth0
> eth0      Link encap:Ethernet  HWaddr 90:2b:34:a0:16:d8
>           inet adr:192.168.23.105  Bcast:192.168.23.255
> Masque:255.255.255.0
>           adr inet6: fe80::922b:34ff:fea0:16d8/64 Scope:Lien
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:456 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:237 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 lg file transmission:1000
>           RX bytes:43079 (42.0 KiB)  TX bytes:32650 (31.8 KiB)
>           Interruption:40 Adresse de base:0xa000
>
> And I do everything using "hbasetest" name.
>
> You can ignore the IPV6 lines in the hosts file.
>
> JM
>
> 2013/7/16 Pavan Sudheendra <pavan0591@gmail.com>
>
>> Jean, can you post an example HBase stand-alone /etc/hosts file?
>> It would be very helpful.
>>
>> On Tue, Jul 16, 2013 at 5:43 PM, Jean-Marc Spaggiari
>> <jean-marc@spaggiari.org> wrote:
>> > I will say it should be your host name. Not the IP nor "localhost".
>> >
>> > 2013/7/16 Rohit Kelkar <rohitkelkar@gmail.com>
>> >
>> >> Depends on what your /etc/hosts file says
>> >>
>> >> On Tuesday, July 16, 2013, Pavan Sudheendra wrote:
>> >>
>> >> > Ah. The value of quorun should be localhost or my ip address?
>> >> >
>> >> > On Tue, Jul 16, 2013 at 5:32 PM, Rohit Kelkar <rohitkelkar@gmail.com>
>> >> > wrote:
>> >> > > I suggested that because you were able to use the shell but not
the
>> >> > client
>> >> > > code.
>> >> > >
>> >> > > - R
>> >> > >
>> >> > > On Tuesday, July 16, 2013, Pavan Sudheendra wrote:
>> >> > >
>> >> > >> Yes Jean, It is working fine.
>> >> > >> @Rohit, i thought in the standalone mode it is not required.
>> >> > >>
>> >> > >> On Tue, Jul 16, 2013 at 5:25 PM, Rohit Kelkar <
>> rohitkelkar@gmail.com>
>> >> > >> wrote:
>> >> > >> > In your client code can you try explicitly setting values
of
>> >> > >> > hbase.zookeeper.quorum
>> >> > >> >
>> >> > >> > - R
>> >> > >> >
>> >> > >> > On Tuesday, July 16, 2013, Jean-Marc Spaggiari wrote:
>> >> > >> >
>> >> > >> >> Hi Pavan,
>> >> > >> >>
>> >> > >> >> You should try to avoid localhost. Try to prefers
your host
>> name.
>> >> Is
>> >> > >> >> http://ubuntu:60010/master-status?filter=all<
>> >> > >> >> http://localhost:60010/master-status?filter=all>working
>> >> > >> >> fine?
>> >> > >> >>
>> >> > >> >> JM
>> >> > >> >>
>> >> > >> >> 2013/7/16 Pavan Sudheendra <pavan0591@gmail.com>
>> >> > >> >>
>> >> > >> >> > Hi all,
>> >> > >> >> > I further went to
>> >> http://localhost:60010/master-status?filter=alland
>> >> > >> >> > checked that:
>> >> > >> >> > [{"statustimems":-1,"status":"Waiting for a
>> >> > >> >> > call","starttimems":1373948304755,"description":"REPL
IPC
>> Server
>> >> > >> >> > handler 2 on
>> >> > >> >> >
>> >> > >> >>
>> >> > >>
>> >> >
>> >>
>> 38039","state":"WAITING","statetimems":-1},{"statustimems":-1,"status":"Waiting
>> >> > >> >> > for a call","starttimems":1373948304755,"description":"REPL
>> IPC
>> >> > Server
>> >> > >> >> > handler 1 on
>> >> > >> >> >
>> >> > >> >>
>> >> > >>
>> >> >
>> >>
>> 38039","state":"WAITING","statetimems":-1},{"statustimems":-1,"status":"Waiting
>> >> > >> >> > for a call","starttimems":1373948304755,"description":"REPL
>> IPC
>> >> > Server
>> >> > >> >> > handler 0 on 38039","state":"WAITING","statetimems":-1},
>> >> > >> >> >
>> >> > >> >> > all the rpc calls gets stuck on waiting.. and
my master it
>> says
>> >> > active
>> >> > >> >> > on the tasks page for a while and dissapears.
Any help much
>> >> > >> >> > appreciated.
>> >> > >> >> >
>> >> > >> >> > On Tue, Jul 16, 2013 at 8:54 AM, Pavan Sudheendra
<
>> >> > >> pavan0591@gmail.com>
>> >> > >> >> > wrote:
>> >> > >> >> > > @Kim how is that possible? I'm using the
stable release.
>> >> > >> >> > >
>> >> > >> >> > > On Tue, Jul 16, 2013 at 8:37 AM, Pavan
Sudheendra <
>> >> > >> pavan0591@gmail.com
>> >> > >> >> >
>> >> > >> >> > wrote:
>> >> > >> >> > >> @Jean, Nope, it didn't work. I even
re-installed hbase.
>> >> > >> >> > >>
>> >> > >> >> > >> Has anyone worked with the Hbase-The
definitive guide
>> examples
>> >> > with
>> >> > >> >> > >> standalone mode?
>> >> > >> >> > >>
>> >> > >> >> > >> On Mon, Jul 15, 2013 at 10:06 PM, Kim
Chew <
>> >> kchew534@gmail.com>
>> >> > >> >> wrote:
>> >> > >> >> > >>> Another thing is,
>> >> > >> >> > >>>
>> >> > >> >> > >>> 2013-07-15 05:15:58,764 WARN org.apache.hadoop.ipc.
>> >> > >> >> > >>> HBaseServer:
>> >> > >> >> > >>> Incorrect header or version mismatch
from 127.0.0.1:46149
>> got
>> >> > >> >> vers--
>> >> > Regards-
>> >> > Pavan
>> >> >
>> >>
>>
>>
>>
>> --
>> Regards-
>> Pavan
>>



-- 
Regards-
Pavan

Mime
View raw message