hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Junyoung Kim <henry.jy...@gmail.com>
Subject have you ever met this error?
Date Fri, 26 Jul 2013 04:00:51 GMT
Hi, hbase users.

have you ever met this kinds of errors?

2013-07-25 18:29:16,859 ERROR org.apache.hadoop.hbase.regionserver.metrics.SchemaMetrics:
Inconsistent configuration. Previous configuration for using table name in metrics: true,
new configuration: false
2013-07-25 18:29:16,859 ERROR org.apache.hadoop.hbase.regionserver.metrics.SchemaMetrics:
Inconsistent configuration. Previous configuration for using table name in metrics: true,
new configuration: false
2013-07-25 18:29:16,859 ERROR org.apache.hadoop.hbase.regionserver.metrics.SchemaMetrics:
Inconsistent configuration. Previous configuration for using table name in metrics: true,
new configuration: false


AIK, this errors are from hbase configurations(hbase-site.xml).

  <property>
    <name>hbase.metrics.showTableName</name>
    <value>true</value>
    <description>Whether to include the prefix "tbl.tablename" in per-column family
metrics.
      If true, for each metric M, per-cf metrics will be reported for tbl.T.cf.CF.M, if false,
      per-cf metrics will be aggregated by column-family across tables, and reported for cf.CF.M.
      In both cases, the aggregated metric M across tables and cfs will be reported.
    </description>
  </property>

this property is also defined in hbase-default.xml.
the important thing is both file set the value as true.

I don't who set this property to false!! who did override it?
any helps?
Mime
View raw message