hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yves S. Garret" <yoursurrogate...@gmail.com>
Subject Re: HBase is not running.
Date Fri, 24 May 2013 20:01:10 GMT
The thing that gets me, really gets me, is that the only thing inside of
/etc/hosts is this:
127.0.0.1    localhost

Also, I did a search for host.name and could not find it in any html files
(which I presume is the documentation).


On Fri, May 24, 2013 at 12:41 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> Ah yeah the master advertised itself as:
>
> Attempting connect to Master server at
> ip72-215-225-9.at.at.cox.net,46122,1369408257140
>
> So the region server cannot find it since that's the public address
> and nothing's reachable through that. Now you really need to fix your
> networking :)
>
> J-D
>
> On Fri, May 24, 2013 at 8:21 AM, Yves S. Garret
> <yoursurrogategod@gmail.com> wrote:
> > Ok, weird, it still seems to be looking towards Cox.
> >
> > Here is my hbase-site.xml file:
> > http://bin.cakephp.org/view/628322266
> >
> >
> > On Thu, May 23, 2013 at 7:35 PM, Jean-Daniel Cryans <jdcryans@apache.org
> >wrote:
> >
> >> No, I meant hbase.master.ipc.address and
> >> hbase.regionserver.ipc.address. See
> >> https://issues.apache.org/jira/browse/HBASE-8148.
> >>
> >> J-D
> >>
> >> On Thu, May 23, 2013 at 4:34 PM, Yves S. Garret
> >> <yoursurrogategod@gmail.com> wrote:
> >> > Do you mean hbase.master.info.bindAddress and
> >> > hbase.regionserver.info.bindAddress?  I couldn't find
> >> > anything else in the docs.  But having said that, both
> >> > are set to 0.0.0.0 by default.
> >> >
> >> > Also, I checked out 127.0.0.1:60010 and 0.0.0.0:60010,
> >> > no web gui.
> >> >
> >> >
> >> > On Thu, May 23, 2013 at 7:19 PM, Jean-Daniel Cryans <
> jdcryans@apache.org
> >> >wrote:
> >> >
> >> >> It should only be a matter of network configuration and not a matter
> >> >> of whether you are a Hadoop expert or not. HBase is just trying to
> get
> >> >> the machine's hostname and bind to it and in your case it's given
> >> >> something it cannot use. It's unfortunate.
> >> >>
> >> >> IIUC your machine is hosted on cox.net? And it seems that while
> >> >> providing that machine they at some point set it up so that its
> >> >> hostname would resolve to a public address. Sounds like a
> >> >> misconfiguration. Anyways, you can edit your /etc/hosts so that your
> >> >> hostname points to 127.0.0.1 or, since you are using 0.94.7, set both
> >> >> hbase.master.ipc.address and hbase.regionserver.ipc.address to
> 0.0.0.0
> >> >> in your hbase-site.xml so that it binds on the wildcard address
> >> >> instead.
> >> >>
> >> >> J-D
> >> >>
> >> >> On Thu, May 23, 2013 at 4:07 PM, Yves S. Garret
> >> >> <yoursurrogategod@gmail.com> wrote:
> >> >> > How weird.  Admittedly I'm not terribly knowledgeable about Hadoop
> >> >> > and all of its sub-projects, but I don't recall ever setting any
> >> >> networking
> >> >> > info to something other than localhost.  What would cause this?
> >> >> >
> >> >> >
> >> >> > On Thu, May 23, 2013 at 6:26 PM, Jean-Daniel Cryans <
> >> jdcryans@apache.org
> >> >> >wrote:
> >> >> >
> >> >> >> That's your problem:
> >> >> >>
> >> >> >> Caused by: java.net.BindException: Problem binding to
> >> >> >> ip72-215-225-9.at.at.cox.net/72.215.225.9:0 : Cannot assign
> >> requested
> >> >> >> address
> >> >> >>
> >> >> >> Either it's a public address and you can't bind to it or someone
> else
> >> >> >> is using it.
> >> >> >>
> >> >> >> J-D
> >> >> >>
> >> >> >> On Thu, May 23, 2013 at 3:24 PM, Yves S. Garret
> >> >> >> <yoursurrogategod@gmail.com> wrote:
> >> >> >> > Here is my dump of the sole log file in the logs directory:
> >> >> >> > http://bin.cakephp.org/view/2116332048
> >> >> >> >
> >> >> >> >
> >> >> >> > On Thu, May 23, 2013 at 6:20 PM, Jean-Daniel Cryans <
> >> >> jdcryans@apache.org
> >> >> >> >wrote:
> >> >> >> >
> >> >> >> >> On Thu, May 23, 2013 at 2:50 PM, Jay Vyas <
> jayunit100@gmail.com>
> >> >> wrote:
> >> >> >> >> > 1) Should hbase-master be changed to localhost?
> >> >> >> >> >
> >> >> >> >> > Maybe Try changing /etc/hosts to match the actual
non
> loopback
> >> ip
> >> >> of
> >> >> >> >> your machine... (i.e. just run Ifconfig | grep 1
and see what
> ip
> >> >> comes
> >> >> >> out
> >> >> >> >> :))
> >> >> >> >> >  and make sure your /etc/hosts matches the file
in my blog
> post,
> >> >> (you
> >> >> >> >> need hbase-master to be defined in your /etc/hosts...).
> >> >> >> >>
> >> >> >> >> hbase.master was dropped around 2009 now that we
have
> zookeeper.
> >> So
> >> >> >> >> you can set it to whatever you want, it won't change
anything
> :)
> >> >> >> >>
> >> >> >> >> >
> >> >> >> >> > 2) zookeeper parent seems bad..
> >> >> >> >> >
> >> >> >> >> > Change hbase-rootdir to "hbase" (in hbase.rootdir)
so that
> it's
> >> >> >> >> consistent with what you defined in zookeeper parent
node.
> >> >> >> >>
> >> >> >> >> Those two are really unrelated, /hbase is the default
so no
> need
> >> to
> >> >> >> >> override it, and I'm guessing that hbase.rootdir
is somewhere
> >> >> writable
> >> >> >> >> so that's all good.
> >> >> >> >>
> >> >> >> >> Now, regarding the "Check the value configured in
> >> >> >> >> 'zookeeper.znode.parent", it's triggered when the
client wants
> to
> >> >> read
> >> >> >> >> the /hbase znode in ZooKeeper but it's unable to.
If it doesn't
> >> >> exist,
> >> >> >> >> it might be because your HBase is homed elsewhere.
It could
> also
> >> be
> >> >> >> >> that HBase isn't running at all so the Master never
got to
> create
> >> it.
> >> >> >> >>
> >> >> >> >> BTW you can start the shell with -d and it's gonna
give more
> info
> >> and
> >> >> >> >> dump all the stack traces.
> >> >> >> >>
> >> >> >> >> Going by this thread I would guess that HBase isn't
running so
> the
> >> >> >> >> shell won't help. Another way to check is pointing
your
> browser to
> >> >> >> >> localhost:60010 and see if the master is responding.
If not,
> time
> >> to
> >> >> >> >> open up the log and see what's up.
> >> >> >> >>
> >> >> >> >> J-D
> >> >> >> >>
> >> >> >>
> >> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message