hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vimal Jain <vkj...@gmail.com>
Subject Re: Not able to connect to Hbase remotly
Date Wed, 22 May 2013 12:35:25 GMT
Hi,
I got below Runtime exception after i changed my catch block ( from
catch(IOException) to catch(Exception) ). Sorry for trouble.
Exception :
org.apache.hadoop.hbase.client.NoServerForRegionException: Unable to find
region for event_data

where "event_data" is the table i have created in Hbase through shell

hbase(main):001:0> list
TABLE

event_data

event_data2

test

3 row(s) in 2.5320 seconds

what could be wrong ?


On Wed, May 22, 2013 at 5:53 PM, Vimal Jain <vkjk89@gmail.com> wrote:

> I had attached it.May be attachments are blocked.
> Attachments are big.How do i send it ?
>
>
> On Wed, May 22, 2013 at 5:47 PM, Jyothi Mandava <jyothi.Mandava@huawei.com
> > wrote:
>
>> Could not find the logs.
>>
>> From: Vimal Jain [mailto:vkjk89@gmail.com]
>> Sent: 22 May 2013 17:18
>> To: user@hbase.apache.org
>> Subject: Re: Not able to connect to Hbase remotly
>>
>> Yes.
>> I tried creating some tables , and it works fine.
>> I have attached my master and zookeeper logs.
>>
>> On Wed, May 22, 2013 at 5:11 PM, Jyothi Mandava <
>> jyothi.Mandava@huawei.com<mailto:jyothi.Mandava@huawei.com>> wrote:
>> Is the cluster ok? Have you tried creating table or any other operation
>> using Shell where master is involved?
>>
>> Do you see anything in Master logs? Pls share your ZK log ( and master if
>> there is any useful info).
>>
>> Regards,
>> Jyothi.
>> -----Original Message-----
>> From: Vimal Jain [mailto:vkjk89@gmail.com<mailto:vkjk89@gmail.com>]
>> Sent: 22 May 2013 16:55
>> To: user@hbase.apache.org<mailto:user@hbase.apache.org>
>> Subject: Re: Not able to connect to Hbase remotly
>>
>> Hi Tariq,
>> I tried this but its not helping.
>> Let me brief you about the problem.
>> I have posted this on
>>
>> http://stackoverflow.com/questions/16689594/unable-to-connect-to-hbase-remotly
>> Please help.
>>
>>
>> On Wed, May 22, 2013 at 4:41 PM, Mohammad Tariq <dontariq@gmail.com
>> <mailto:dontariq@gmail.com>> wrote:
>>
>> > Hello Vimal,
>> >
>> >         Add the IP and hostname of your HBase machine into the hosts
>> > file of your client machine and see if it helps.
>> >
>> > Warm Regards,
>> > Tariq
>> > cloudfront.blogspot.com<http://cloudfront.blogspot.com>
>> >
>> >
>> > On Wed, May 22, 2013 at 4:38 PM, Vimal Jain <vkjk89@gmail.com<mailto:
>> vkjk89@gmail.com>> wrote:
>> >
>> > > Hi Jyothi,
>> > > I am running my hbase in pseudo distributed mode so zookeeper and
>> > > master are on same machine.
>> > >
>> > >
>> > >
>> > > On Wed, May 22, 2013 at 4:28 PM, Jyothi Mandava
>> > > <jyothi.Mandava@huawei.com<mailto:jyothi.Mandava@huawei.com>>wrote:
>> > >
>> > > > Connection between master and zookeeper are ok? Have you verified
>> > > > if
>> > your
>> > > > cluster is working fine (zookeeper to master connection)?
>> > > > I had connection issue though the IP was set in configuration and
>> > > > connection was tried with host. Adding hosts entry resolved the
>> issue.
>> > > But
>> > > > no errors at client in your case.
>> > > > In case if you already had an entry in hosts file, make sure the
>> > > > host
>> > > name
>> > > > to IP mapping is correct and no mismatches.
>> > > >
>> > > > Jyothi
>> > > >
>> > > >
>> > > > -----Original Message-----
>> > > > From: Vimal Jain [mailto:vkjk89@gmail.com<mailto:vkjk89@gmail.com>]
>> > > > Sent: 22 May 2013 15:42
>> > > > To: user@hbase.apache.org<mailto:user@hbase.apache.org>
>> > > > Subject: Re: Not able to connect to Hbase remotly
>> > > >
>> > > > No exception at client side .
>> > > > Code just hangs on call to htablepool.getTable(tableName) In
>> > > > zookeeper logs , i am able to see that it received a request for
>> > > > connection from
>> > > Java
>> > > > program but it did not proceed ahead.
>> > > >
>> > > > Any reason to add 192.168.0.181 in /etc/hosts , because as per my
>> > > > understanding  /etc/hosts is used for hostname-ip conversion and i
>> > > > am already proving IP address.
>> > > > Yes,both machines can access each other.
>> > > >
>> > > >
>> > > > On Wed, May 22, 2013 at 3:37 PM, Jyothi Mandava
>> > > > <jyothi.Mandava@huawei.com<mailto:jyothi.Mandava@huawei.com>>wrote:
>> > > >
>> > > > > Hi,
>> > > > >
>> > > > > Code seem to be fine. Getting any exceptions at client side?
>> > > > > Does your client machine hosts file has an entry for
>> 192.168.0.181?
>> > > > > Both machines able to access each other?
>> > > > >
>> > > > > Regards,
>> > > > > Jyothi
>> > > > >
>> > > > > -----Original Message-----
>> > > > > From: Vimal Jain [mailto:vkjk89@gmail.com<mailto:vkjk89@gmail.com
>> >]
>> > > > > Sent: 22 May 2013 15:18
>> > > > > To: user@hbase.apache.org<mailto:user@hbase.apache.org>
>> > > > > Subject: Re: Not able to connect to Hbase remotly
>> > > > >
>> > > > > Hi,
>> > > > > Yes Jyothi.
>> > > > > Here is my Java code
>> > > > >            Configuration config = HBaseConfiguration.create();
>> > > > >            config.set("hbase.zookeeper.quorum" ,192.168.0.181);
>> > > > >
>>  config.set("hbase.zookeeper.property.clientPort","2181");
>> > > > >            tablePool = new HTablePool(config,Integer.MAX_VALUE);
>> > > > >
>> > > > > Anything wrong ?
>> > > > >
>> > > > >
>> > > > > On Wed, May 22, 2013 at 3:10 PM, Jyothi Mandava
>> > > > > <jyothi.Mandava@huawei.com<mailto:jyothi.Mandava@huawei.com
>> >>wrote:
>> > > > >
>> > > > > > Hi,
>> > > > > >
>> > > > > > How are you trying to connect?
>> > > > > > Are you setting zookeeper host and client port in
>> > HBaseConfiguration?
>> > > > > >
>> > > > > > Regards,
>> > > > > > Jyothi
>> > > > > >
>> > > > > > -----Original Message-----
>> > > > > > From: Vimal Jain [mailto:vkjk89@gmail.com<mailto:
>> vkjk89@gmail.com>]
>> > > > > > Sent: 22 May 2013 14:57
>> > > > > > To: user@hbase.apache.org<mailto:user@hbase.apache.org>
>> > > > > > Subject: Not able to connect to Hbase remotly
>> > > > > >
>> > > > > > Hi,
>> > > > > > I have Hbase configured in pseudo distributed mode on Machine
A.
>> > > > > > I would like to connect to it through a Java program running
>> > > > > > on Machine
>> > > > > B.
>> > > > > > But i am unable to do so.What configurations are required
in
>> > > > > > Java for this ?
>> > > > > > Please help.
>> > > > > >
>> > > > > > --
>> > > > > > Thanks and Regards,
>> > > > > > Vimal Jain
>> > > > > >
>> > > > >
>> > > > >
>> > > > >
>> > > > > --
>> > > > > Thanks and Regards,
>> > > > > Vimal Jain
>> > > > >
>> > > >
>> > > >
>> > > >
>> > > > --
>> > > > Thanks and Regards,
>> > > > Vimal Jain
>> > > >
>> > >
>> > >
>> > >
>> > > --
>> > > Thanks and Regards,
>> > > Vimal Jain
>> > >
>> >
>>
>>
>>
>> --
>> Thanks and Regards,
>> Vimal Jain
>>
>>
>>
>> --
>> Thanks and Regards,
>> Vimal Jain
>>
>
>
>
> --
> Thanks and Regards,
> Vimal Jain
>



-- 
Thanks and Regards,
Vimal Jain

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message