hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Boesch <java...@gmail.com>
Subject Simple but Reliable configuration for pseudo distributed mode on ubuntu
Date Wed, 22 May 2013 19:33:58 GMT
I have not been able to bring up a simple standalone hbase pseuo
distributed mode cluster on a single ubuntu 12.x machine.  A couple of
co-workers that have been using hbase for years also looked at it and we
have not been able to resolve.

Before I jump in to the details, i'll just say : "hey is there a pointer to
a well known configuration that just works?"  I don't have any special
requirements beyond the following:
       ubuntu 12.x
       single machine pseudo distributed
       preference for hbase 0.92.2 but not a showstopper for newer versions
       apache (not cdh, etc) hadoop 1.X (version not important to me beyond

Some more details on the setup:

   using hadoop 1.0.3 .  HDFS and map/reduce been working fine for months
   hbase 0.92.2
   zookeeper: have tried both hbase manages zk=true as well as false (and
with zk 3.3.6)
   hdfs: using localhost:8020
   Launching hbase with start-hbase.sh
         master comes up
         regiion server comes up
         region server shows as "region in transition" and never
completes/never starts serving regions
         Appears that master does not register properly with ZK - though
there *is * a new  /hbase/master node in zookeeper , it oes not have any

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message