hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raju muddana <rajumudd...@gmail.com>
Subject Re: HBase Support
Date Sun, 12 May 2013 06:48:30 GMT
Hey shashwat,!

I have already Seen some of your posts related to Hbase.At that time those
are Very Helpful to Me.
And Thank you to you once again fro this reply.

Shashwat i did not find any "addresources("",value)" method. I found
"addresource()"
and is takes only single parameter.
So i set the values using set(key,value) method.Is It ok?

Thanks & Regards
Raju.


On Sat, May 11, 2013 at 11:56 PM, shashwat shriparv <
dwivedishashwat@gmail.com> wrote:

> in your code add this parameter
> zookeeper.session.timeout
> zookeeper tick tome
> conf.addresources("",value)
>
>
>
> *Thanks & Regards    *
>
> ∞
> Shashwat Shriparv
>
>
>
> On Sat, May 11, 2013 at 9:22 PM, Mohammad Tariq <dontariq@gmail.com>
> wrote:
>
> > Hello Raju,
> >
> >         Please add the scheme i.e. "file://" in your URI so that is looks
> > like "file:///home/imadas/24H-DB". And yes, there is no need to
> > specify hbase.master
> > in hbase-site.xml, as Shahab has said.
> >
> > Warm Regards,
> > Tariq
> > cloudfront.blogspot.com
> >
> >
> > On Sat, May 11, 2013 at 9:10 PM, Shahab Yunus <shahab.yunus@gmail.com
> > >wrote:
> >
> > > @naga raju. You should not provide hbase.master property. The
> information
> > > is retrieved from the zookeeper.quorum property instead.
> > >
> > >
> > > On Sat, May 11, 2013 at 8:39 AM, naga raju <rajumuddana@gmail.com>
> > wrote:
> > >
> > > > Thanks Tariq,
> > > >
> > > > my hbase-site.xml:
> > > >
> > > >  <configuration>
> > > > <property>
> > > >     <name>hbase.rootdir</name>
> > > >     <value>/home/imadas/24H-DB</value>
> > > > </property>
> > > >
> > > > <property>
> > > >    <name>hbase.rpc.timeout</name>
> > > >    <value>900000</value> <!-- 15 minutes -->
> > > > </property>
> > > >
> > > > <property>
> > > >    <name>hbase.zookeeper.quorum</name>
> > > >    <value>127.0.0.1</value>
> > > > </property>
> > > >
> > > > <property>
> > > >    <name>hbase.master</name>
> > > >    <value>127.0.0.1:60000</value>
> > > >    <description>The host and port that the HBase master runs
> > > > at.</description>
> > > > </property>
> > > >
> > > > <property>
> > > >    <name>zookeeper.session.timeout</name>
> > > >    <value>180000</value>
> > > > </property>
> > > >
> > > > <property>
> > > >     <name>hbase.zookeeper.property.dataDir</name>
> > > >     <value>/home/imadas/zookeeperfolder</value>
> > > > </property>
> > > >
> > > > </configuration>
> > > >
> > > >
> > > > Thanks & Regards
> > > > Raju.
> > > >
> > > >
> > > > On Fri, May 10, 2013 at 8:20 PM, Mohammad Tariq <dontariq@gmail.com>
> > > > wrote:
> > > >
> > > > > You are welcome Raju,
> > > > >
> > > > >           There seems to be some connection related issue. Could
> you
> > > > please
> > > > > show me you hbase-site.xml?Have you added "hbase.zookeeper.quorum"
> in
> > > > > it?Which version are you using?
> > > > >
> > > > > Warm Regards,
> > > > > Tariq
> > > > > cloudfront.blogspot.com
> > > > >
> > > > >
> > > > > On Fri, May 10, 2013 at 8:01 PM, naga raju <rajumuddana@gmail.com>
> > > > wrote:
> > > > >
> > > > > > Thank you Tariq,
> > > > > >
> > > > > > Have checked Hbase Master Logs(Which i have Provided to you).
> > > > > >  Did you find any clue to identify what is the Problem.
> > > > > >
> > > > > > Thanks & Regards
> > > > > > Raju.
> > > > > >
> > > > > >
> > > > > > On Fri, May 10, 2013 at 7:01 PM, Mohammad Tariq <
> > dontariq@gmail.com>
> > > > > > wrote:
> > > > > >
> > > > > > > Hello Raju,
> > > > > > >
> > > > > > >       ZK logs should be there  at the same place as HMaster
> logs.
> > > > > > >
> > > > > > > Warm Regards,
> > > > > > > Tariq
> > > > > > > cloudfront.blogspot.com
> > > > > > >
> > > > > > >
> > > > > > > On Fri, May 10, 2013 at 5:24 PM, naga raju <
> > rajumuddana@gmail.com>
> > > > > > wrote:
> > > > > > >
> > > > > > > > Thanks Tariq,
> > > > > > > >
> > > > > > > > I am Using hbase-0.92.1,
> > > > > > > >
> > > > > > > > This is some part of Hbase Master log file:
> > > > > > > >
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> environment:java.library.path=/home/imadas/softs/hbase-0.92.1/bin/../lib/native/Linux-i386-32
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > > environment:java.io.tmpdir=/tmp
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > > environment:java.compiler=<NA>
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> environment:
> > > > > os.name
> > > > > > > > =Linux
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > environment:os.arch=i386
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > > environment:os.version=2.6.32-220.el6.i686
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> environment:
> > > > > > user.name
> > > > > > > > =imadas
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > > environment:user.home=/home/imadas
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Client
> > > > > > > > environment:user.dir=/home/imadas/softs/hbase-0.92.1
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ZooKeeper: Initiating
client
> > > > > > connection,
> > > > > > > > connectString=127.0.0.1:2181 sessionTimeout=180000
> > > > > watcher=hconnection
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ClientCnxn: Opening
socket
> > > > > connection
> > > > > > to
> > > > > > > > server /127.0.0.1:2181
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.RecoverableZooKeeper:
The
> > > > identifier
> > > > > > of
> > > > > > > > this process is 3145@localhost.localdomain
> > > > > > > > 13/05/10 14:22:22 WARN client.ZooKeeperSaslClient:
> > > > SecurityException:
> > > > > > > > java.lang.SecurityException: Unable to locate a login
> > > configuration
> > > > > > > > occurred when trying to find JAAS configuration.
> > > > > > > > 13/05/10 14:22:22 INFO client.ZooKeeperSaslClient:
Client
> will
> > > not
> > > > > > > > SASL-authenticate because the default JAAS configuration
> > section
> > > > > > 'Client'
> > > > > > > > could not be found. If you are not using SASL, you
may ignore
> > > this.
> > > > > On
> > > > > > > the
> > > > > > > > other hand, if you expected SASL to work, please fix
your
> JAAS
> > > > > > > > configuration.
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ClientCnxn: Socket
> connection
> > > > > > > established
> > > > > > > > to localhost.localdomain/127.0.0.1:2181, initiating
session
> > > > > > > > 13/05/10 14:22:22 INFO zookeeper.ClientCnxn: Session
> > > establishment
> > > > > > > complete
> > > > > > > > on server localhost.localdomain/127.0.0.1:2181, sessionid
=
> > > > > > > > 0x13e8d9972b00004, negotiated timeout = 40000
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > and kindly Tell me Where I can Found Zookeeper logs.
> > > > > > > >
> > > > > > > > Thanks & Regards.
> > > > > > > > Raju.
> > > > > > > >
> > > > > > > >
> > > > > > > > On Fri, May 10, 2013 at 4:14 PM, Mohammad Tariq <
> > > > dontariq@gmail.com>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > Hello Raju,
> > > > > > > > >
> > > > > > > > >       This means that there is some problem with
the
> > connection
> > > > > > between
> > > > > > > > > HMaster and ZK. Make sure all your Hbase daemons
are
> running
> > > > fine.
> > > > > > > Which
> > > > > > > > > version are you using?Also showing complete HMaster
and ZK
> > logs
> > > > > would
> > > > > > > be
> > > > > > > > > helpful.
> > > > > > > > >
> > > > > > > > > Warm Regards,
> > > > > > > > > Tariq
> > > > > > > > > cloudfront.blogspot.com
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Fri, May 10, 2013 at 11:54 AM, naga raju <
> > > > rajumuddana@gmail.com
> > > > > >
> > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > ya I have checked Logs ,in those logs i
found ..
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > WARN client.ZooKeeperSaslClient: SecurityException:
> > > > > > > > > > java.lang.SecurityException: Unable to locate
a login
> > > > > configuration
> > > > > > > > > > occurred when trying to find JAAS configuration.
> > > > > > > > > >
> > > > > > > > > > lient.ZooKeeperSaslClient: Client will not
> > SASL-authenticate
> > > > > > because
> > > > > > > > the
> > > > > > > > > > default JAAS configuration section 'Client'
could not be
> > > found.
> > > > > If
> > > > > > > you
> > > > > > > > > are
> > > > > > > > > > not using SASL, you may ignore this. On
the other hand,
> if
> > > you
> > > > > > > expected
> > > > > > > > > > SASL to work, please fix your JAAS configuration.
> > > > > > > > > >
> > > > > > > > > > WARN zookeeper.ClientCnxn: Session 0x0 for
server null,
> > > > > unexpected
> > > > > > > > error,
> > > > > > > > > > closing socket connection and attempting
reconnect
> > > > > > > > > > java.net.ConnectException: Connection refused
> > > > > > > > > >     at sun.nio.ch.SocketChannelImpl.checkConnect(Native
> > > Method)
> > > > > > > > > >     at
> > > > > > > > > >
> > > > > > >
> > > >
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:574)
> > > > > > > > > >     at
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:286)
> > > > > > > > > >     at
> > > > > > > > >
> > > > >
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1035)
> > > > > > > > > >
> > > > > > > > > > WARN zookeeper.RecoverableZooKeeper: Possibly
transient
> > > > ZooKeeper
> > > > > > > > > > exception:
> > > > > > > > org.apache.zookeeper.KeeperException$ConnectionLossException:
> > > > > > > > > > KeeperErrorCode = ConnectionLoss for /hbase/master
> > > > > > > > > >
> > > > > > > > > > What this means?
> > > > > > > > > >
> > > > > > > > > > Thanks & Regards.
> > > > > > > > > > Raju.
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > On Fri, May 10, 2013 at 11:37 AM, Amandeep
Khurana <
> > > > > > amansk@gmail.com
> > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > > Look at your HBase logs. They will
be in the
> > > $HBASE_HOME/logs
> > > > > > > > > directory.
> > > > > > > > > > > That might give some insight into what's
going on.
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On Thu, May 9, 2013 at 10:42 PM, naga
raju <
> > > > > > rajumuddana@gmail.com>
> > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > > Thanks for your Guidance  Amandeep,
> > > > > > > > > > > >
> > > > > > > > > > > > I can re-start my application
and which logs i have
> to
> > > > check.
> > > > > > > > > > > >
> > > > > > > > > > > > Thank & Regards
> > > > > > > > > > > > Raju.
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > On Fri, May 10, 2013 at 11:07
AM, Amandeep Khurana <
> > > > > > > > amansk@gmail.com
> > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > > Can you tell what the logs
are saying? Did you try
> to
> > > > > restart
> > > > > > > > your
> > > > > > > > > > > > > application?
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Thu, May 9, 2013 at 10:36
PM, naga raju <
> > > > > > > > rajumuddana@gmail.com>
> > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > > > Thanks for the Reply
Amandeep,
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > I can access the web
UI.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Fri, May 10, 2013
at 10:52 AM, Amandeep
> Khurana
> > <
> > > > > > > > > > amansk@gmail.com
> > > > > > > > > > > >
> > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > What do the HBase
logs say? Can you access the
> > web
> > > > UI?
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On Thu, May 9,
2013 at 9:57 PM, naga raju <
> > > > > > > > > rajumuddana@gmail.com
> > > > > > > > > > >
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > I am running
hbase on same(single) system
> > which i
> > > > am
> > > > > > > using
> > > > > > > > to
> > > > > > > > > > > > > > > development.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On Fri, May
10, 2013 at 6:19 AM, Amandeep
> > > Khurana <
> > > > > > > > > > > > amansk@gmail.com>
> > > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Are you
running HBase on your local
> > development
> > > > box
> > > > > > or
> > > > > > > on
> > > > > > > > > > some
> > > > > > > > > > > > > server
> > > > > > > > > > > > > > > > > outside
and trying to connect to it from
> your
> > > dev
> > > > > > box?
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > On Thu,
May 9, 2013 at 6:36 AM, raju <
> > > > > > > > > rajumuddana@gmail.com>
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
Hi all,
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
  I am New to Hbase(Hadoop), and i am
> > working
> > > > on
> > > > > > > hbase
> > > > > > > > > with
> > > > > > > > > > > > > > > standalone
> > > > > > > > > > > > > > > > > >
mode.My application running well for some
> > > time,
> > > > > > after
> > > > > > > > > that
> > > > > > > > > > it
> > > > > > > > > > > > > > > displays
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
INFO zookeeper.ClientCnxn: Client session
> > > timed
> > > > > > out,
> > > > > > > > have
> > > > > > > > > > not
> > > > > > > > > > > > > heard
> > > > > > > > > > > > > > > > from
> > > > > > > > > > > > > > > > > >
server in 29946ms for sessionid
> > > > > 0x13e88be25cc0004,
> > > > > > > > > closing
> > > > > > > > > > > > socket
> > > > > > > > > > > > > > > > > >
connection
> > > > > > > > > > > > > > > > > >
and attempting reconnect
> > > > > > > > > > > > > > > > > >
.....
> > > > > > > > > > > > > > > > > >
.....
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
and continuing this message.Then my
> > > application
> > > > > > will
> > > > > > > > not
> > > > > > > > > > > > > > communicate
> > > > > > > > > > > > > > > > with
> > > > > > > > > > > > > > > > > >
hbase.
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
I have Searched in net,but could not
> found
> > > any
> > > > > > stuff
> > > > > > > to
> > > > > > > > > > > resolve
> > > > > > > > > > > > > > this
> > > > > > > > > > > > > > > > > >
issue.Please guide me.
> > > > > > > > > > > > > > > > > >
I want to know...
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
1.what are the causes of  Client session
> > > timed
> > > > > > > out.(and
> > > > > > > > > > > client
> > > > > > > > > > > > > > > session
> > > > > > > > > > > > > > > > > >
scenario)
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
2.How zookeeper and master and client
> will
> > > > > > > communicate
> > > > > > > > in
> > > > > > > > > > > > > > standalone
> > > > > > > > > > > > > > > > mode
> > > > > > > > > > > > > > > > > >
as
> > > > > > > > > > > > > > > > > >
well as in distributed mode.
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
3.If there are any configurations to
> modify
> > > > > please
> > > > > > > let
> > > > > > > > me
> > > > > > > > > > > know.
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
Thanks & Regards.
> > > > > > > > > > > > > > > > > >
raju.
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message