hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: hbase-0.94.6.1 balancer issue
Date Fri, 12 Apr 2013 16:06:00 GMT
Hi Samir,

Regions are balancer per table.

So if you have 48 regions within the same table, it should be split about
24 on each server.

But if you have 48 tables with 1 region each, the for each table, the
balancer will see only 1 region and will display the message you saw.

Have you looked at the UI? What do you have in it? Can you please confirm
if yo uhave 48 tables or 1 table?

Thanks,

JM


2013/4/12 Samir Ahmic <ahmic.samir@gmail.com>

> Hi, all
>
> I'm evaluating hbase-0.94.6.1 and i have 48 regions on 2 node cluster. I
> was restarting on of RSs and after that tried to balance cluster by running
> balancer from shell. After running command regions were not distributed to
> second RS and i found this line i master log:
>
> 2013-04-12 16:45:15,589 INFO org.apache.hadoop.hbase.master.LoadBalancer:
> Skipping load balancing because balanced cluster; servers=2 *regions=1
> *average=0.5
> mostloaded=1 leastloaded=0
>
> This look like to me that wrong number of regions is reported by balancer
> and that cause of  skipping load balancing . In hbase shell i see all 48
> tables that i have and everything else looks fine.
>
> Did someone else see this type of behavior ? Did something changed around
> balancer in hbase-0.94.6.1 ?
>
> Regards
> Samir
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message