hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajna Jacob <rajna.ja...@gmail.com>
Subject error when starting hbase
Date Tue, 23 Apr 2013 13:08:13 GMT
Hello,

I didn't manage to make hbase work properly and i would need some help
please, I already read helps on the forum and couldn't find what i did
wrong.

I'm using the version 0.94.6.1 on ubuntu 12.04 and I'm trying it in local
host.

I already verified my localhost adress is 127.0.0.1

I used the command  ./bin/start-hbase.sh and got some errors and warnings
in the logs :

2013-04-23 14:45:19,248 WARN
org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper: Node
/hbase/backup-masters/rmm-p1188629fl.ads.local,60782,1366721118837 already
deleted, and this is not a retry

2013-04-23 14:45:19,277 WARN org.apache.hadoop.hbase.util.FSUtils: Unable
to create version file at file:/app/hbase, retrying: Mkdirs failed to
create file:/app/hbase

2013-04-23 14:45:29,278 WARN org.apache.hadoop.hbase.util.FSUtils: Unable
to create version file at file:/app/hbase, retrying: Mkdirs failed to
create file:/app/hbase
2013-04-23 14:45:39,278 WARN org.apache.hadoop.hbase.util.FSUtils: Unable
to create version file at file:/app/hbase, retrying: Mkdirs failed to
create file:/app/hbase
2013-04-23 14:45:49,279 FATAL org.apache.hadoop.hbase.master.HMaster:
Unhandled exception. Starting shutdown.

Then i can access the shell with ./bin/hbase shell but i couldn't create
any table with the create command.

here is what i put in my hbase-site.xml

<configuration>
<property>
    <name>hbase.rootdir</name>
    <value>file:///app/hbase</value>
  </property>
  <property>
    <name>hbase.zookeeper.property.dataDir</name>
    <value>app/zookeeper</value>
  </property>
</configuration>

You can find attached to the e-mail my complete log file.

I hope you can find what my problem is.

Thank you,
Sincerely yours

Rajna Jacob.

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message