hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Scanner returning subset of data
Date Mon, 08 Apr 2013 21:18:39 GMT
0.92.1 is pretty old. Are you able to deploy newer release, e.g. 0.94.6.1
and see if the problem can be reproduced ?

Otherwise we have two choices:
1. write a unit / integration test that shows this bug
2. see more of the region server / client logs so that further analysis can
be performed.

Thanks

On Mon, Apr 8, 2013 at 2:07 PM, Randy Fox <randy.fox@connexity.com> wrote:

> I have a needle-in-the-haystack type scan.  I have tried to read all the
> issues with ScannerTimeoutException and LeaseException, but do have not
> seen anyone report what I am seeing.
>
> Running 0.92.1-cdh4.1.1.  All config wrt to timeouts and periods are
> default: 60s.
>
> When I run a scanner that will return few results and my cache setting is
> a bit too high for results to return in 60 seconds, i sometimes get a
> subset of results (the last few returnable rows) and no exception.  it may
> take a while to get those results.  Other times I get the LeaseException,
> the ScannerTimeoutException, or the RetriesExhaustedException. I can see
> throwExceptionIfCallerDisconne**cted in RS logs.
>
> The incorrect return set has me very concerned.  I can easily reproduce
> this with my own code or hbase shell.
>
> Any help is greatly appreciated.
>
> Cheers,
>
> Randy Fox
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message