hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ramkrishna vasudevan <ramkrishna.s.vasude...@gmail.com>
Subject Re: regionserver stucking
Date Wed, 17 Apr 2013 09:31:05 GMT
The compactsplitthread is not responding to the interrupt call that happens
thro shutdownNow().
So either the thread has already got interrupted and the call to
shutdownnow is not taking effect.  Not very sure of the problem.

Which version of HBase ? Any logs available?

Regards
Ram


On Wed, Apr 17, 2013 at 2:48 PM, hua beatls <beatls@gmail.com> wrote:

> HI,
>     from stack pid,  innormal state:
>    SIGTERM handler" daemon prio=10 tid=0x00007f8f34005800 nid=0x5281
> waiting for monitor entry [0x00007f8f57303000]
> java.lang.Thread.State: BLOCKED (on object monitor)
> at java.lang.Shutdown.exit(Shutdown.java:212)
>     what the reason?
>
>     Thanks!
>      beatls
>
>
> On Wed, Apr 17, 2013 at 4:54 PM, Mohammad Tariq <dontariq@gmail.com>
> wrote:
>
> > You could make use of jVisualVM as well. Comes in quite handy.
> >
> > Warm Regards,
> > Tariq
> > https://mtariq.jux.com/
> > cloudfront.blogspot.com
> >
> >
> > On Wed, Apr 17, 2013 at 2:05 PM, ramkrishna vasudevan <
> > ramkrishna.s.vasudevan@gmail.com> wrote:
> >
> > > Just do jstack with pid.
> > >
> > > Regards
> > > Ram
> > >
> > >
> > > On Wed, Apr 17, 2013 at 1:56 PM, hua beatls <beatls@gmail.com> wrote:
> > >
> > > > any good tool for thread dump? can you recommand?
> > > >
> > > > Thanks!
> > > >
> > > > beatls
> > > >
> > > >
> > > > On Wed, Apr 17, 2013 at 4:06 PM, ramkrishna vasudevan <
> > > > ramkrishna.s.vasudevan@gmail.com> wrote:
> > > >
> > > > > Can you attach a thread dump for this ?  Which version of HBase are
> > you
> > > > > using.
> > > > >
> > > > > Logs also if attached would be fine.
> > > > >
> > > > > Regards
> > > > > Ram
> > > > >
> > > > >
> > > > > On Wed, Apr 17, 2013 at 1:07 PM, hua beatls <beatls@gmail.com>
> > wrote:
> > > > >
> > > > > > HI,
> > > > > >    from web ui I find one of my 5 regionserver missing,   and
> check
> > > the
> > > > > log
> > > > > > find:
> > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> *****************************************************************************************
> > > > > > [hadoop@hadoop1 logs]$ tail -f
> > hbase-hadoop-regionserver-hadoop1.log
> > > > > > 2013-04-17 15:21:24,789 DEBUG
> > > > > > org.apache.hadoop.hbase.regionserver.CompactSplitThread: Waiting
> > for
> > > > > Split
> > > > > > Thread to finish...
> > > > > > 2013-04-17 15:22:24,789 DEBUG
> > > > > > org.apache.hadoop.hbase.regionserver.CompactSplitThread: Waiting
> > for
> > > > > Split
> > > > > > Thread to finish...
> > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> *********************************************************************************************
> > > > > >     but the regionserver process is still alive from jps output.
> > > > > >
> > > > > >      any suggestion?
> > > > > >
> > > > > >     Thanks!
> > > > > >
> > > > > >     beatls
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message