hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kyle Lin <kylelin2...@gmail.com>
Subject Web UI shows not deployed but hbase shell works fine
Date Fri, 22 Mar 2013 04:08:23 GMT
Hello everybody

    I saw the unusual status on WEB UI(see the attached image). But HBase
Shell still works fine. I can scan, put, create table, drop table.
Sometimes restarting HBase can get rid of this status, but this time not
work.

    How can I resolve this error? I've tried "hbase hbck -fix", "hbase hbck
-fisAssignments", "hbase hbck -repair".......The status is still the same.

    When looking up master log, I can see many familiar message as follows.
Looks like assignments not worked.

2013-03-22 12:05:52,403 DEBUG org.apache.hadoop.hbase.master.ServerManager:
New connection to host4,60020,1363920966832
2013-03-22 12:05:52,411 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: Handling
transition=RS_ZK_REGION_OPENING, server=host4,60020,1363920966832,
region=85cf7ff5bc30d7314108c8317a5c3995
2013-03-22 12:05:52,420 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: Handling
transition=RS_ZK_REGION_FAILED_OPEN, server=host4,60020,1363920966832,
region=85cf7ff5bc30d7314108c8317a5c3995
2013-03-22 12:05:52,420 DEBUG
org.apache.hadoop.hbase.master.handler.ClosedRegionHandler: Handling CLOSED
event for 85cf7ff5bc30d7314108c8317a5c3995
2013-03-22 12:05:52,420 DEBUG
org.apache.hadoop.hbase.master.AssignmentManager: Forcing OFFLINE;
was=t1,,1363846090898.85cf7ff5bc30d7314108c8317a5c3995. state=CLOSED,
ts=1363925158716, server=host4,60020,1363920966832

* My HBase version is 0.94.0 with 1 Master/Zookeeper node and 2
regionserver nodes.*


Kyle



[image: 內置圖片 1]

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message