hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tianying Chang <tich...@ebaysf.com>
Subject RE: status of bin/rename_table.rb
Date Thu, 21 Feb 2013 18:30:02 GMT
I already fixed this script to make it working mid last year, we used it in our production
since. Also we don't need to run hbck -fix afterwards.  The script works for both 92 and 94.
 I will publish my patch. 

Thanks
Tian-Ying 

-----Original Message-----
From: Harsh J [mailto:harsh@cloudera.com] 
Sent: Thursday, February 21, 2013 10:13 AM
To: user@hbase.apache.org
Subject: Re: status of bin/rename_table.rb

Hi Tian-Ying,

If the need is urgent, try out the solution from Shrijeet at
https://issues.apache.org/jira/browse/HBASE-643 (see my comment there at around end). We tried
it out earlier today for another purpose, and it had a few hitches but nothing unfixable by
"hbck -fix".

On Thu, Feb 21, 2013 at 11:36 PM, Tianying Chang <tichang@ebaysf.com> wrote:
> Our customers need to use rename_table to solve an issue in our production cluster. Since
92 does not have it, we copied it from CDH3. However it does not work. I then found several
issues with it, and fixed them. We used it in our production cluster to rename some very big
tables. Even when the cluster was shutdown during the rename_table (test purpose), the script
will continue the rename and succeed if invoking the same rename command again after cluster
is back.
>
> I think it is helpful to have rename_table script handy. I can open a jira and attach
my patch.
>
> Thanks
> Tian-Ying
>
> -----Original Message-----
> From: saint.ack@gmail.com [mailto:saint.ack@gmail.com] On Behalf Of 
> Stack
> Sent: Monday, October 15, 2012 11:57 AM
> To: user@hbase.apache.org
> Subject: Re: status of bin/rename_table.rb
>
> On Mon, Oct 15, 2012 at 8:25 AM, Norbert Burger <norbert.burger@gmail.com> wrote:
>> Hi folks,
>>
>> Does anyone have a good working process for renaming tables?  From 
>> the links below, I gather that the bin/rename_table.rb (last included 
>> in
>> 0.90.x) had a few issues.
>>
>> http://search-hadoop.com/m/TVnYN1OEdOT/Hbase%253A+Table+rename&subj=r
>> e
>> naming+table
>> http://search-hadoop.com/m/uAfm51RZCl42/Hbase%253A+Table+rename&subj=
>> H
>> base+Table+rename
>>
>> I tried rename_table.rb a few times with some of our larger tables 
>> and did have some issues with .META., but it's not clear to me if 
>> these issues were caused by rename_table or not.
>>
>
> The script has gone stale.  It is removed in trunk and should have probably been removed
earlier.
>
> That said, its pretty basic what it does.  What sort of issues are you seeing?  Does
running disable/enable help?
>
> St.Ack



--
Harsh J

Mime
View raw message