hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Smieszny <ad...@cloudera.com>
Subject Re: Region Servers Issue
Date Wed, 02 Jan 2013 13:52:35 GMT
Redirecting to hbase-user

Thanks,
Adam


On Tue, Jan 1, 2013 at 4:29 PM, Dalia Hassan <daliahassan0@gmail.com> wrote:

> Dear all,
>
> I am trying to test the performance of hbase by increasing number of nodes.
>
> I am running a Java Program that uses Aggregate Implementation Coprocessor
> i.e count the number of rows based on a specific filter. Then I am testing
> by increasing the number of region servers will the time taken to execute
> this program will less or not ? Suppose it will be.
>
> But unfortunately, it produces the same time.
>
> What I am doing actually is:
>
>    1. I have the number of rows to be 4 million.
>    2. Then I ran the code, given that the cluster contains one region
>    server , the time was approximately 16 seconds.
>    3. After that I added another region server to the cluster i.e so now
>    cluster has 2 region servers.
>    4. By running the code, it took the same app 16 seconds.
>
>
> So my question is what to do to feel the difference ? Also by adding a
> second region server, will the 2 million records move to it ? If so, how
> much time will it take ?
>
> Thanks,
>
> Waiting for your responses asap.
>



-- 
Adam Smieszny
Cloudera | Systems Engineer | http://www.linkedin.com/in/adamsmieszny
917.830.4156

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message