hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Hbase tables disappear
Date Mon, 14 Jan 2013 17:21:35 GMT
On Mon, Jan 14, 2013 at 6:12 AM, Ibrahim Yakti <iyakti@souq.com> wrote:

> Hello,
> I have a weird issue, I am using sqoop to import data from MySQL into
> HBase, sqoop confirms that 2.5 million records were imported, when I do
> count "table_name" in HBase shell it returns numbers like:
> 260970 row(s) in 20.4740 seconds
> >
> (I have used sqoop to import same data from mysql to hive and it worked
> smoothly without any problem)
> when I run the count command again the number may change without any change
> to the table, the other weird issue, if I reboot the server and run HBase
> shell all the tables will be disappeared and I have to create them again.
Default location for hbase data is /tmp unless you change it so a reboot
will erase all you loaded into hbase.   See

Any idea what is going and where the problem is?

Are you overwriting old data with new?

Start small and work your way up to bigger numbers.  You might get a clue
as to where the data is going.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message