hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lashing <lss...@gmail.com>
Subject Re: Hbase hbck -repair slow
Date Tue, 15 Jan 2013 17:13:02 GMT
Thanks Kevin , it looks like this option is only available in 0.90.7


"Kevin O'dell" <kevin.odell@cloudera.com> 於 2013/1/15 下午11:56 寫道:

> If you have only lost your META, I would just use:
> 
> hbase hbck -fixMeta -fixAssignments
> 
> This will rebuild your META
> 
> On Tue, Jan 15, 2013 at 10:53 AM, Lashing <lsshiu@gmail.com> wrote:
> 
>> Kevin
>>      Thanks for the update. Actually you can think of the whole meta is
>> missing , or say deleted.
>> Can multiple hbck repair table run at the same time ?
>> 
>> "Kevin O'dell" <kevin.odell@cloudera.com> 於 2013/1/15 下午11:20 寫道:
>> 
>>> Lashing,
>>> 
>>> Without knowning the exact errors you are seeing it would be hard to
>> make
>>> recommendations.  If it is just META that is messed up you can use:
>>> 
>>> hbase hbck -fixMeta -fixAssignments
>>> 
>>> I think(not sure) in that version you can do
>>> 
>>> hbase hbck -repair <tablename>
>>> 
>>> This will let you target a specific table to speed up the repair process.
>>> 
>>> On Tue, Jan 15, 2013 at 10:08 AM, Lashing <lsshiu@gmail.com> wrote:
>>> 
>>>> We recently suffered meta corrupt issue. We tried to use hbck -repair to
>>>> fix
>>>> But the performance is not fast (about 1 region for 1 second). Are there
>>>> any better way to speed up the process?
>>>> Btw, My Hbase is 0.90.6. Thanks.
>>> 
>>> 
>>> 
>>> 
>>> --
>>> Kevin O'Dell
>>> Customer Operations Engineer, Cloudera
>> 
> 
> 
> 
> -- 
> Kevin O'Dell
> Customer Operations Engineer, Cloudera

Mime
View raw message