hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: 答复: Best practice for the naming convention of column family
Date Wed, 28 Nov 2012 15:12:59 GMT
Then on your code, just refer to it as a constant, like:
public static final byte[] CF_COLUMN_NAME = Bytes.toBytes("d");

On all your calls you will then use CF_COLUMN_NAME...

JM

2012/11/28, 冯宏华 <fenghonghua@xiaomi.com>:
> according to "http://hbase.apache.org/book.html#number.of.cfs" - "6.3.2.1.
> Column Families" : Try to keep the ColumnFamily names as small as possible,
> preferably one character (e.g. "d" for data/default).
> ________________________________________
> 发件人: Ramasubramanian Narayanan [ramasubramanian.narayanan@gmail.com]
> 发送时间: 2012年11月28日 13:51
> 收件人: user@hbase.apache.org
> 主题: Best practice for the naming convention of column family
>
> Hi,
>
> Can anyone suggest the best practice for the naming convention for the
> column family pls..
>
> regards,
>
> Rams
>

Mime
View raw message