hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wanli gao <dsgs...@gmail.com>
Subject Re: hbase error
Date Wed, 21 Nov 2012 17:42:23 GMT
zookeeper is running well,
regionserver log:
2012-11-22 00:54:53,773 INFO 
org.apache.hadoop.hbase.regionserver.HRegionServer: HRegionServer 
started at: 127.0.0.1:60020
2012-11-22 00:54:53,774 INFO org.apache.hadoop.ipc.HBaseServer: IPC 
Server handler 24 on 60020: starting
2012-11-22 00:54:53,774 DEBUG 
org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Failed to read: 
org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = 
NoNode for /hbase/root-region-server
2012-11-22 00:54:53,791 INFO 
org.apache.hadoop.hbase.regionserver.StoreFile: Allocating LruBlockCache 
with maximum size 197.4m
2012-11-22 00:54:53,812 INFO 
org.apache.hadoop.hbase.regionserver.HRegionServer: MSG_REGION_OPEN: 
-ROOT-,,0
2012-11-22 00:54:53,815 INFO 
org.apache.hadoop.hbase.regionserver.HRegionServer: Worker: 
MSG_REGION_OPEN: -ROOT-,,0
2012-11-22 00:54:53,841 DEBUG 
org.apache.hadoop.hbase.regionserver.HRegion: Creating region -ROOT-,,0, 
encoded=70236052
2012-11-22 00:54:53,871 INFO 
org.apache.hadoop.hbase.regionserver.HRegion: region -ROOT-,,0/70236052 
available; sequence id is 0
2012-11-22 00:54:53,897 DEBUG 
org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Failed to read: 
org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = 
NoNode for /hbase/root-region-server
2012-11-22 00:54:54,938 DEBUG 
org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Read ZNode 
/hbase/root-region-server got 127.0.0.1:60020
2012-11-22 00:55:53,808 DEBUG 
org.apache.hadoop.hbase.io.hfile.LruBlockCache: Cache Stats: Sizes: 
Total=0.9263153MB (971312), Free=196.52368MB (206070016), Max=197.45MB 
(207041328), Counts: Blocks=0, Access=0, Hit=0, Miss=0, Evictions=0, 
Evicted=0, Ratios: Hit Ratio=NaN%, Miss Ratio=NaN%, Evicted/Run=NaN
mater log:
2012-11-22 00:55:32,964 INFO org.apache.zookeeper.ClientCnxn: Server 
connection successful
2012-11-22 00:55:32,988 DEBUG 
org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Read ZNode 
/hbase/master got 127.0.0.1:60000
2012-11-22 00:55:33,021 DEBUG 
org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Read ZNode 
/hbase/root-region-server got 127.0.0.1:60020
2012-11-22 00:55:33,024 DEBUG 
org.apache.hadoop.hbase.client.HConnectionManager$TableServers: Found 
ROOT at 127.0.0.1:60020
2012-11-22 00:55:50,944 INFO 
org.apache.hadoop.hbase.master.ServerManager: 1 region servers, 0 dead, 
average load 1.0
2012-11-22 00:55:51,110 INFO org.apache.hadoop.hbase.master.BaseScanner: 
RegionManager.rootScanner scanning meta region {server: 127.0.0.1:60020, 
regionname: -ROOT-,,0, startKey: <>}
2012-11-22 00:55:51,117 INFO org.apache.hadoop.hbase.master.BaseScanner: 
RegionManager.rootScanner scan of 0 row(s) of meta region {server: 
127.0.0.1:60020, regionname: -ROOT-,,0, startKey: <>} complete
于 2012年11月22日 01:32, Stack 写道:
> What do the logs say?
> St.Ack
>
> On Wed, Nov 21, 2012 at 7:44 AM, wanli gao <dsgsghs@gmail.com> wrote:
>> hi all,
>> i m now running hbase on pseudo-distributed mode, and when i open hbase
>> webUI: http://localhost:60010/master.jsp,its give an error:
>> Trying to contact region server null for region , row '', but failed
>> after 3 attempts.
>> Exceptions:
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> org.apache.hadoop.hbase.TableNotFoundException: .META.
>> and when i run list on hbase it give the same error,
>> my hbase-site.xml is :
>>
>> <configuration>
>> <property>
>> <name>hbase.rootdir</name>
>> <value>hdfs://localhost:9000/hbase</value>
>> </property>
>> <property>
>> <name>hbase.cluster.distributed</name>
>> <value>true</value>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.clientPort</name>
>> <value>5000</value>
>> <description>Property from ZooKeeper's config zoo.cfg.
>> The port at which the clients will connect.
>> </description>
>> </property>
>> <property>
>> <name>hbase.zookeeper.quorum</name>
>> <value>localhost</value>
>> </property>
>> <property>
>> <name>hbase.tmp.dir</name>
>> <value>/home/wanli/hadoop/hbasetmp</value>
>> <description>Temporary directory on the local filesystem.</description>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.dataDir</name>
>> <value>home/wanli/hadoop/hbasezook</value>
>> </property>
>> <property>
>> <name>hbase.zookeeper.property.clientPort</name>
>> <value>6500</value>
>> <description>Property from ZooKeeper config zoo.cfg.</description>
>> </property>
>> </configuration>
>>
>> is there anyone know this error,
>> thanks


Mime
View raw message