hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay Whittaker <...@stealthintelligence.co.uk>
Subject Failed to move out of transition timeout
Date Fri, 17 Aug 2012 10:54:14 GMT

After having issues with M/R not completing due to lease timeouts we saw that in the webui
there were no regions listed for the problem table. So we tried hbck –repair and were getting
this bug https://issues.apache.org/jira/browse/HBASE-6018 . So we upgraded to 0.94.1 and we
are seeing regions in the webui again but one region is coming up not deployed.

Hbck –repair comes back with an error of "failed to move out of transition within timeout
120000ms". I have tried "assign 'region name'" in hbase shell but that just comes back  0
row(s) in 28.0950 seconds.

Hadoop fsck is coming back fine too.

Unsure how to fix the region from here or even remove it so we can use the rest of the data

Jay Whittaker

Stealth Intelligence Ltd

[Description: Description: Description: Description: Description: Description: Stealth_logo]

E-mail   :   jay@stealthintelligence.co.uk<mailto:jay@stealthintelligence.co.uk>
Skype    :  stealth.three
Phone   :  07803146993

This e-mail communication & any attachments are confidential & for the sole use of
the intended recipient(s). Any review, reliance, dissemination, distribution, copying or other
use is strictly prohibited & may be illegal.

Any opinions expressed in this communication are personal & are not attributable to Stealth
Intelligence or any of its associate companies.

The reliability of this method of communication cannot be guaranteed. It can be intercepted,
corrupted, delayed, may arrive incomplete, contain viruses or be affected by other interference.
We have taken reasonable steps to reduce risks against viruses but cannot accept liability
for any damages sustained as a result of this transmission.

If you are not the intended recipient please delete this e-mail & notify the sender immediately
by replying to this e-mail.

  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message