hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohammad Tariq <donta...@gmail.com>
Subject Re: Zookeeper Client port issue
Date Wed, 01 Aug 2012 05:21:37 GMT
Hello Manu,

     Use only one HTable instance at a time, and do not forget to
close it once you are done. If you need multiple HTables, use
HTablePool class instead. HTablePool acts as a pool for all tables.

Regards,
    Mohammad Tariq


On Wed, Aug 1, 2012 at 9:55 AM, Manu S <manupkd87@gmail.com> wrote:
> Hi All,
>
> In our Fully distributed Hbase cluster setup we have given zookeeper *
> clientPort=2181*. Everything was working fine
>
> Recently I got an error from HBase shell
> *ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able
> to connect to ZooKeeper but the connection closes immediately. This could
> be a sign that the server has too many connections (30 is the default).
> Consider inspecting your ZK server logs for that error and then make sure
> you are reusing HBaseConfiguration as often as you can. See HTable's
> javadoc for more information*.
>
> I tried restarting zookeeper & hbase, but not helped. But when I change the
> *clientPort *to some random port its worked.It happened twice. Changing the
> clientPort is not an ideal solution as the same port is configured in our
> applications.
>
> Is there any permanent fix for this issue?
>
> Appreciate your help on the same.
>
> Thanks,
> Manu S

Mime
View raw message