hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiran Gangadharan <kiran.darede...@gmail.com>
Subject HBase client program not able to identify/read existing table
Date Thu, 23 Aug 2012 07:32:41 GMT
Hi,

I am trying to connect to HBase locally from my client Java Program when I
get this error:

Encountered problems when prefetch META table:
org.apache.hadoop.hbase.TableNotFoundException: Cannot find row in .META.
for table: "XYZ", row="XYZ",,99999999999999

HBase Version: hbase-0.94.0

What I've already tried:

   1. Double checking the configurations
   2. Making sure that the table exists (And yes it is visible from the
   shell)
   3. Deleting the .META. folder in hbase datasource directory
   4. Deleting the local datasource folder
   5. Tried running hbck -repair which apparently shows 0 inconsistencies

I've tried all of the above, but still no success.

I tried to do some googling of this error message, and found out that this
was a HBase bug which was supposedly solved in HBase-0.94.0 release. But i
don't know why I'm still facing this problem.

Can someone please help me out ? Thanks in advance.

The question posted on *Stack Overflow*:
http://stackoverflow.com/questions/12085637/hbase-client-program-not-able-to-identify-read-existing-table

Cheers,
-- 
Kiran Gangadharan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message