hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gemini alex <gemini5201...@gmail.com>
Subject Re: Issue with creating table in hbase
Date Thu, 16 Aug 2012 09:24:18 GMT
it seems you didn't start hive with --aux-path as mentioned in hive hbase
integration document.


2012/8/15 Kevin O'dell <kevin.odell@cloudera.com>

> What happens if you paste that into the hive shell?
>
> On Tue, Aug 14, 2012 at 11:05 AM, Omer, Farah <fomer@microstrategy.com
> >wrote:
>
> > Hi all,
> >
> > I was testing hbase integrated with Hive, and running into an issue.
> Would
> > anyone has an idea what it means?
> >
> >
> >
> > hbase(main):001:0> CREATE TABLE hbase_mstr_1(key int, value string)
> STORED
> > BY 'org.apache.hadoop.hive.hbase.HBaseStorageHandler' WITH
> SERDEPROPERTIES
> > ("hbase.columns.mapping" = ":key,cf1:val") TBLPROPERTIES ("
> > hbase.table.name" = "xyz")
> >
> > SyntaxError: (hbase):1: syntax error, unexpected tIDENTIFIER
> >
> >
> >
> > CREATE TABLE hbase_mstr_1(key int, value string) STORED BY
> > 'org.apache.hadoop.hive.hbase.HBaseStorageHandler' WITH SERDEPROPERTIES
> > ("hbase.columns.mapping" = ":key,cf1:val") TBLPROPERTIES ("
> > hbase.table.name" = "xyz")
> >
> >                                               ^
> >
> >
> >
> > hbase(main):002:0>
> >
> >
> >
> > Hive version is 0.7, hbase version is 0.90
> >
> >
> >
> > Farah Omer
> >
> > Sr. DB Engineer | MicroStrategy, Inc.
> >
> > Tel 703.270.2230 | fomer@microstrategy.com
> >
> > 1850 Towers Crescent Plaza | Tysons Corner, VA 22182
> >
> > www.microstrategy.com
> >
> >
> >
>
>
> --
> Kevin O'Dell
> Customer Operations Engineer, Cloudera
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message