hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AnandaVelMurugan Chandra Mohan <ananthu2...@gmail.com>
Subject Re: Connection error while usinh HBase client API for pseudodistrbuted mode
Date Tue, 03 Jul 2012 12:07:20 GMT
Hi,

These are text from the files

/etc/hosts

127.0.0.1       localhost


# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

hbase-site.xml

<configuration>
<property>
      <name>hbase.rootdir</name>
      <value>hdfs://localhost/user/eucalyptus/hbase</value>
      <description>The directory shared by RegionServers.
      </description>
    </property>
</configuration>


On Tue, Jul 3, 2012 at 4:14 PM, Mohammad Tariq <dontariq@gmail.com> wrote:

> Can you paste the contents of your /etc/hosts and hbase-site.xml files??
>
> Regards,
>     Mohammad Tariq
>
>
> On Tue, Jul 3, 2012 at 4:06 PM, AnandaVelMurugan Chandra Mohan
> <ananthu2050@gmail.com> wrote:
> > Hi,
> >
> > Thanks for the response. Sadly I am still getting same error.
> >
> >
> > On Tue, Jul 3, 2012 at 3:58 PM, Mohammad Tariq <dontariq@gmail.com>
> wrote:
> >
> >> Hello Ananda,
> >>
> >>           Add these two lines in your client and sww if it works for
> you :
> >>
> >> config.set("hbase.zookeeper.property.clientPort","2181");
> >> config.set("hbase.master", "localhost:60000");
> >>
> >> Regards,
> >>     Mohammad Tariq
> >>
> >>
> >> On Tue, Jul 3, 2012 at 3:49 PM, AnandaVelMurugan Chandra Mohan
> >> <ananthu2050@gmail.com> wrote:
> >> > Hi,
> >> >
> >> > For development purpose, I have set up HBase in pseudodistributed
> mode.
> >> >
> >> > I have following line in hbase-env.sh file
> >> >
> >> > export HBASE_MANAGES_ZK=true
> >> >
> >> > HBase shell works fine. But client API is not working.
> >> >
> >> > My client code is as follows
> >> >
> >> >                  Configuration config = HBaseConfiguration.create();
> >> >                 config.set("hbase.zookeeper.quorum", "10.78.32.131");
> >> >                 config.setBoolean("hbase.cluster.distributed", false);
> >> >                 HBaseAdmin admin = new HBaseAdmin(config);
> >> >                 admin.isMasterRunning();
> >> >
> >> > System.out.println(admin.getClusterStatus().getHBaseVersion());
> >> >
> >> > I am getting java.net.ConnectException: Connection refused: no further
> >> > information.
> >> >
> >> > Any idea, how it can be fixed. Please let me know. Thanks!!
> >> > --
> >> > Regards,
> >> > Anand
> >>
> >
> >
> >
> > --
> > Regards,
> > Anand
>



-- 
Regards,
Anand

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message