hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arvid Warnecke <ar...@nostalgix.org>
Subject Re: Enable Snappy compression - not able to load the libs on startup
Date Mon, 09 Jul 2012 17:44:02 GMT
Hello Harsh,

On Mon, Jul 09, 2012 at 07:14:56AM +0530, Harsh J wrote:
> Perhaps the pre-compiled set does not work against the version of libs
> in your ArchLinux. We've noticed this to be the case between CentOS 5
> and 6 versions too (5 doesn't pick up the Snappy codec for some
> reason).
> 
> Try recompiling them on the hadoop side (ant compile-native, etc.).
> For a loose dependency set to compile the natives, see
> http://wiki.apache.org/hadoop/QwertyManiac/BuildingHadoopTrunk.
> Alternatively, you can also run the CDH build script under
> $HADOOP_HOME/cloudera/do-release-build to get it going automatically
> and producing a new tarball.
> 
Thank you for those suggestions. I tried to rebuild with ant, which
broke with some useless error message and I tried to use the
do-release-build script which threw some other errors. At last I tried
to build only the snappy sources which had been downloaded via the
do-release-build script....

What really did the trick was not to use ./bin/hbase-start.sh to start
up the Master and Regionserver, but to use ./bin/hbase-daemon.sh start
master and ./bin/hbase-daemon.sh start regionserver.

I did not find the main difference between those scripts yet to tell
what is missing in the start-hbase.sh.

Cheers,
Arvid

-- 
[ Arvid Warnecke ][ arvid (at) nostalgix (dot) org ]
[ IRC/OPN: "madhatter" ][ http://www.nostalgix.org ]
---[  ThreePiO was right: Let the Wookiee win.  ]---

Mime
View raw message