hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Kim <benkimkim...@gmail.com>
Subject Re: ColumnCountGetFilter not working with FilterList
Date Wed, 30 May 2012 01:11:05 GMT
Ram, you are right PageFilter won't work either

I filed hbase jira at https://issues.apache.org/jira/browse/HBASE-6132

On Tue, May 29, 2012 at 10:49 PM, Ramkrishna.S.Vasudevan <
ramkrishna.vasudevan@huawei.com> wrote:

> Discussing with Anoop I think PageFilter also may not work when used with
> FilterList. Need to check this.
> Please file a JIRA for the same we can look into all possibilities.
>
> Regards
> Ram
>
>
> > -----Original Message-----
> > From: Anoop Sam John [mailto:anoopsj@huawei.com]
> > Sent: Tuesday, May 29, 2012 5:22 PM
> > To: user@hbase.apache.org
> > Subject: RE: ColumnCountGetFilter not working with FilterList
> >
> > Hi Ben,
> >             Is this the same code you are testing?  Which version of
> > HBase you are testing with? I have checked with 0.94 and it works fine
> > ( with FilterList also )
> >
> > -Anoop-
> >
> > ________________________________________
> > From: Ben Kim [benkimkimben@gmail.com]
> > Sent: Tuesday, May 29, 2012 5:04 PM
> > To: user@hbase.apache.org
> > Subject: ColumnCountGetFilter not working with FilterList
> >
> > This is a straightforward question and problem.
> >
> >             Get get = new Get(rowkey);
> >             FilterList filterList = new FilterList();
> >             filterList.addFilter(new ColumnCountGetFilter(100));
> >             get.setFilter(filterList);
> >             Result r = table.get(get);
> >
> > This returns zero columns where it should have 100 columns.
> > It works well without FilterList.
> >
> > Don't know what went wrong. Any help would be thankful
> >
> >
> > --
> >
> > *Benjamin Kim*
> > *benkimkimben at gmail*
>
>


-- 

*Benjamin Kim*
**Mo : +82 10.5357.0521*
benkimkimben at gmail*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message