hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben West <bwsithspaw...@yahoo.com>
Subject Re: Table that won't delete
Date Mon, 26 Mar 2012 21:52:31 GMT
I fixed this of course right after sending to the mailing list. I had to delete the node from
zookeeper and restart HBase.


----- Original Message -----
From: Ben West <bwsithspawn00@yahoo.com>
To: "user@hbase.apache.org" <user@hbase.apache.org>
Cc: 
Sent: Monday, March 26, 2012 4:40 PM
Subject: Table that won't delete

Hello all,

I accidentally created a table using LZO compression, and I don't have everything set up for
LZO. So I tried to alter the table, but the shell gave me an error that the table was disabled.
Tried to enable, and it said the table was enabled. Couldn't drop the table because it thinks
the table is enabled. So I just shut down hbase and deleted /hbase from HDFS.

Amazingly, HBase still believes my missing table exists:

    hbase(main):002:0> create 'FOO',{NAME=>'D',VERSIONS=>1}

    ERROR: Table already exists: FOO!

Although it doesn't show up in list and I can't describe it or anything.

Does anyone know how I can troubleshoot this? What do I have to remove for HBase to forget
about my table?

Thanks,
-Ben


Mime
View raw message