hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dalia Sobhy <dalia.mohso...@hotmail.com>
Subject Re: Problem with cloudera
Date Wed, 29 Feb 2012 15:38:03 GMT
I checked it n i used telnet but same prob occurred , i tried another method in thrift api
something like getInputProtocol() it worked fine..
But as for createTable n deleteTable no respond !!

Sent from my iPhone

On 2012-02-29, at 3:53 PM, "T Vinod Gupta" <tvinod@readypulse.com> wrote:

> a real simple test would be to do a telnet to port 9090 of server from your
> client machine. make sure that works fine. a server could be listening on
> port 9090, that doesnt mean clients can connect to it.. there could be
> issues with dns, firewall, port forwarding, etc...
> thanks
> 2012/2/29 Dalia Sobhy <dalia.mohsobhy@hotmail.com>
>> Hiii alll,
>> I decided to share with you my problem, because my professor and
>> colleagues were not able to solve it.
>> First I will tell u my configurations : I made a client and sever for
>> hadoop. The server is on ubuntu cloudera 3 update 3 (chd3u3). My client is
>> on my Mac OXs.
>> Second, I used a code for hbase thrift api (democlient.java) in client,
>> the hbase folder I downloaded it from cloudera same release (chd3u3).
>> The problem is when running the program, if I decided to create table or
>> delete table or use any function related to tables, I enter an infinite
>> loop, the client is waiting for the server to respond but the server is not
>> replying to requests.
>> As for the connectivity, I checked that everything is OK, I am sure of
>> thrift server port (9090) and the server is running. Also by checking I
>> found that server and client are connected and seen each others. But as for
>> handling the requests, the server is unable to do so.
>> Here is link for cloudera hbasehttps://
>> ccp.cloudera.com/display/DOC/CDH+Version+and+Packaging+Information
>> So any help ??
>> Best Regards,Dalia Sobhy

View raw message