hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Snively <bsniv...@gmail.com>
Subject Re: Setting up Bloom filter on created/populated table
Date Sun, 12 Feb 2012 21:33:35 GMT
   - On Fri, Feb 10, 2012 at 4:49 AM, bsnively <bsnively@...
<http://gmane.org/get-address.php?address=bsnively%2dRe5JQEeQqe8AvxtiuMwx3w%40public.gmane.org>>
wrote:
   - >
   - > I am trying to test out a POC using HBase -- and am trying to add a bloom
   - > filter to a table that already exists.
   - >
   - > The way I'm trying to add it seems to keep complaining in the
hbase shell --
   - > and I can find any detailed steps of what I'm doing wrong.
   - >
   - > I was trying to do alter 'eventTable', {BLOOMFILTER => 'ROW'}
and different
   - > variations of that.
   - >
   - > Any help on how to create a bloom filter on a table that
already exists --
   - > with a large amount of data in it?
   - >
   -
   - Paste the exception.
   -
   - You should be using 0.92.0 if you want to mess w/ blooms I'd say.
   -
   - St.Ack

I am using the version right before that (I think -- somewhat new to
hbase) -- it's the cloudera distro: hbase-0.90.4-cdh3u2.

Figured bloom filters were an option, since it lists
BLOOMFILTER=>'NONE' as the attribute now.  This is the command I'm
trying to do (after disabling the table):

hbase(main):013:0>  alter 'ExistenceTable', METHOD => 'table_att',
hbase(main):014:0*  BLOOMFILTER => 'ROW'
0 row(s) in 0.1360 seconds

hbase(main):015:0> describe 'ExistenceTable'
DESCRIPTION                                          ENABLED
 {NAME => 'ExistenceTable', FAMILIES => [{NAME => 'I false
 ', BLOOMFILTER => 'NONE', REPLICATION_SCOPE => '0',
  COMPRESSION => 'NONE', VERSIONS => '3', TTL => '21
 47483647', BLOCKSIZE => '65536', IN_MEMORY => 'fals
 e', BLOCKCACHE => 'true'}, {NAME => 'O', BLOOMFILTE
 R => 'NONE', REPLICATION_SCOPE => '0', COMPRESSION
 => 'NONE', VERSIONS => '3', TTL => '2147483647', BL
 OCKSIZE => '65536', IN_MEMORY => 'false', BLOCKCACH
 E => 'true'}]}
1 row(s) in 0.3480 seconds


Unfortunatlye, it still says BLOOMFILTER => 'NONE'.


Any thoughts?

Thanks,
Ben

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message