hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jameson Li <hovlj...@gmail.com>
Subject Re: upgrade hbase from 0.20.6 to 0.92
Date Mon, 20 Feb 2012 06:48:55 GMT
Thanks very much.

And I have another question.
The hbase books said:
If you can, upgrade your zookeeper. If you can’t, 3.4.2 clients should work
against 3.3.X ensembles (HBase makes use of 3.4.2 API).
As I know, zookeeper 3.4.2 is not a stable version.
So I can't upgrade hbase cluster to version 0.92?  Can hbase 0.92 and
zookeeper 3.3 work well?

Jameson Li.

2012/2/17 Stack <stack@duboce.net>

> On Thu, Feb 16, 2012 at 11:13 PM, Jameson Li <hovlj.ei@gmail.com> wrote:
> >> Follow the 0.90 upgrade steps first.  Verify its working properly up
> >> on 0.90.  Then go to 0.92.  Don't try replacing pieces of the tar ball
> >> piecemeal.  Use all of 0.90 (but yes, adjust the confs accordingly).
> >
> > I am sorry that my English is weak poorly and I can't understand:
> >  "Don't try replacing pieces of the tar ball piecemeal.  Use all of
> > 0.90 (but yes, adjust the confs accordingly)"
> >
> > Do you mean:
> > when I do the 0.92 upgrade, I should  use the same way updating 0.90?
> > Just like you mentioned that:
> >> You need to replace your whole install, not just the jar (different
> >> dependencies, supporting scripts have changed, etc.)
> >
>
> Yes.
> St.Ack
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message