hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Purtell <apurt...@yahoo.com>
Subject Re: Hive hbase handler (0.92.0)
Date Wed, 15 Feb 2012 15:32:41 GMT
There is something amiss. The client has seen a ZK transaction ID far ahead of what the ZK
server thinks is the current epoch. Usually this happens if you blow away ZK storage and restart
it, ie you are creating transient ZK quorums. A client that continues to run will remember
the zxid of the old ZK quorum while the new one will start again with a zxid of 0. Another
way this can happen is if you've some how mixed two distinct ZK quorums in your HBase configuration:
it contains the names of servers in two distinct quorums. Those two ZK clusters will have
uncorrelated zxids.

Check your ZK configuration.

Best regards,

    - Andy

On Feb 15, 2012, at 6:34 AM, "Kaluskar, Sanjay" <skaluskar@informatica.com> wrote:

> I am new to hbase, I can't get the Hive handler working. I downloaded
> the latest Hive (0.8.1) which has a handler for 0.89, and based on the
> instructions on
> https://cwiki.apache.org/confluence/display/Hive/HBaseIntegration I
> recompiled hive after updating the hbase, zookeeper and guava versions
> in src/ivy/library.properties to match what hbase 0.92.0 has. The build
> is successful, but a simple create table (from the above wiki) hangs.
> I checked the logs, and looks like the client connection gets refused by
> zookeeper; log repeats the following:
> 2012-02-15 05:33:22,729 INFO
> org.apache.zookeeper.server.NIOServerCnxnFactory: Accepted socket
> connection from /
> 2012-02-15 05:33:22,730 INFO
> org.apache.zookeeper.server.ZooKeeperServer: Refusing session request
> for client / as it has seen zxid 0x30000002c our last
> zxid is 0x2000000f1 client must try another server
> 2012-02-15 05:33:22,730 INFO org.apache.zookeeper.server.NIOServerCnxn:
> Closed socket connection for client / (no session
> established for client)
> BTW everything basic is working on my Hbase cluster (shell commands,
> Java programs to put/get, map-reduce). Am I doing something wrong? Has
> anybody else seen this?
> Thanks,
> -sanjay

View raw message