hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mariah Rose <desert_rose_...@hotmail.com>
Subject How can I configure a simple client to connect to a remote host with only 1 hbase instance.
Date Wed, 25 Jan 2012 23:33:04 GMT

Hi,
I would like to have a client connecting to a remote hbase host with just 1 node running on
there.
hbase-site.xml on server:«<configuration>
  <property>    <name>hbase.zookeeper.quorum</name>    <value>machine_ip</value>
   <description>The directory shared by RegionServers.    </description>  </property>
  <property>    <name>hbase.cluster.distributed</name>    <value>true</value>
   <description>The mode the cluster will be in. Possible values are      false: standalone
and pseudo-distributed setups with managed Zookeeper      true: fully-distributed with unmanaged
Zookeeper Quorum (see hbase-env.sh)    </description>  </property></configuration>
»
regionservers:«machine_ip» Also tried to replace machine_ip with the host full qualified
name, but the result is the same.
Client code:« Configuration config = HBaseConfiguration.create(); config.set("hbase.zookeeper.quorum",
"server_machine_ip"); HBaseAdmin.checkHBaseAvailable(config); System.out.println("HBase is
running!");»
When I run the client I get the following error:«12/01/25 23:28:31 INFO zookeeper.ZooKeeper:
Session: 0x13516e033160016 closedException in thread "main" org.apache.hadoop.hbase.MasterNotRunningException:
Retried 1 times        at org.apache.hadoop.hbase.client.HBaseAdmin.<init>(HBaseAdmin.java:120)»
I tried to search on google, but nothing worked for me... What could be the problem?
Kind regards. 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message