hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanislav Barton <stanislav.bar...@internetmemory.net>
Subject after adding table using add_table.rb, it is not visible (even after enabling)
Date Tue, 10 Jan 2012 12:38:28 GMT
Hello,

I tried to import a table from hbase 0.90.3 to hbase 0.90.4 on a
different cluster by copying the data between those two clusters. I
uploaded the data into HDFS and called add_table.rb on that, that
finished ok. After that i went to hbase shell and did enable
"new_table" which also finished without firing any exception and in
the master log I can see that it registered the the request for table
enabling and finished ok, saying that all (328) regions of that table
are online. Using the UI I can see the new regions being served, but I
cannot see the table in the list of available tables in hbase (neither
gui nor shell). So when I try to scan that table it obviously says
that it does not know such table. When I do disable/enable the new
table there is no exception in the master log what so ever, nor
regions in transion going wild. I just cannot make it appear in the
list of tables.

I have tried hbck and it reports some holes in the new_table's regions
and some inconsistencies, I tried check_meta.rb -fix and restarted the
cluster but no luck there either. I think that even though there are
holes

I am running cloudera distro (cdh3u2) installed via packages on debian system.

I had some problems with the lzo compression in HBase on the new
cluster, but after recompiling and redistributing lzo-hadoop native
support those problems went away (it passes the lzo test without
firing exception).

I also did hcbk on the 0.90.3 cluster and there were no holes
indicated for the table.

Thanks for your help.

--
Stan

Mime
View raw message