hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yonghu <yongyong...@gmail.com>
Subject zookeeper connection problem in pseudo mode
Date Thu, 05 Jan 2012 15:08:22 GMT

I tried the pseudo distribution mode of HBase. The Hadoop version is
0.20.2. I configured the hbase-site.xml as


as same as in core-site.xml and hdfs-site.xml files of Hadoop, separately.

I can successfully start HBase. But when I tried to create a table, I
got following error information:
ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is
able to connect to ZooKeeper but the connection closes immediately.
This could be a sign that the server has too many connections (30 is
the default). Consider inspecting your ZK server logs for that error
and then make sure you are reusing HBaseConfiguration as often as you
can. See HTable's javadoc for more information.

And I checked my ZK log and found:

2012-01-05 15:59:02,909 INFO org.apache.zookeeper.ClientCnxn: Opening
socket connection to server localhost/0:0:0:0:0:0:0:1:2181
2012-01-05 15:59:02,909 WARN org.apache.zookeeper.ClientCnxn: Session
0x134ae4d4a6d0001 for server null, unexpected error, closing socket
connection and attempting reconnect
java.net.ConnectException: Connection refused
	at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
	at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
	at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1119)

This error information appeared repeatly. Can anyone tell how to solve
this problem?



View raw message